Help about transparency on an object

So I want to make the pane of the front lights of my car model transparent, but it seems as I reduce the Alpha element on the Trasparency panel the panes begins to get more invisible (and that’s right) but instead of seeing the lights behind of the pane it just shows black and I dont know how to fix this.

For some reason I can’t attach the .blend file from the ‘manage attachments’ button , any clue on how to do it ?

Attachments



Hello, I wanna make the pane of the front lights of my car model transparent as a real car is. But when I reduce the Alpha on the Transparency panel, instead of seeing the lights behind the pane as they become transparent, I just see a black “background” behind the pane. And I dont know how I can fix this.

For some reason I can’t attach the .blend file to see exactly what’s going on…

Attachments



Are you using transparent shadows ?

For all materials that are receiving shadows from the glass ensure in the material / shadows panel enable ‘Receive Transparent’

You can upload the .blend file via pasteall.org, and post the link here once the file is uploaded.

Could just be a display issue in solid preview mode. In which case you may want to check the “display transparancy” check under the object tab. (Different than the transparancy in the materials tab.) That one used to drive me nuts until somebody at the forums mentioned it.

–edit–

Looking at the headlight on the left, there’s an indentation in one view that’s not there on the other view. Leads me to believe the internal and external faces of the headlight lens are separate meshes, or at least have separate material zones. Check for that and see if you can fix it.