HELP!!! Black Screen on Startup

Hey, I recently got a new computer and tried to download the latest stable version of Blender on it (2.68a) on Blender’s website. Now, I’m not an experienced user of Blender, in fact, I’m still a beginner, but I’m really hoping to learn a lot with Blender. Unfortunately though, when I downloaded it on my new computer, I was greeted with a black screen after opening it. This has never happened to me before on my old computer or anytime I’ve used Blender before. What I found interesting though is that as I hovered my mouse over the black screen I could still see the tiny arrows indicating that I could format the sizing of menu’s in Blender. Hopefully somebody can help me with this problem so I can go back to blending as soon as possible! Below, I’ve listed the spec’s of my system.

OS: Windows 8
Brand: HP
CPU: AMD Elite A10-5750M (Quad Core) 2.5 Ghz
GPU: AMD Radeon HD 8750M
Screen Resolution: 1366*768

I’ve already tried restarting my computer, downloading the latest graphics card drivers, and even just minimizing the Blender window and vigorously dragging it across my screen a bunch of time. I’ve re-installed Blender many times, and also tried older builds of Blender, but they all give me the same black screen I have now. I really hope somebody can help me with this!!

Here’s an image, if you can’t really visualize what the problem is!! D:

Okay, I’ve finally figured out why it didn’t work. I didn’t have a version of python installed in my computer, so for that reason I guess Blender didn’t work. As soon as I downloaded python, Blender began to function like it did on my old computer!

Glad I could be of some help… (Also glad you posted the solution after you found it.)