Help Blender can't find Python Win & 64 bit

Hello, I just installed Windows 7 64 bit, Then I installed python and Blender 2.49 as well as Blender 2.50 ( also 64 bit versions). When I run any ver of Blender it can’t find the installed Python and falls back to the bundled Python. Win 7 has changed the way it does some things with programs and as I am new I don’t Know what it does, (though it does seem to be doing things similar to Ubuntu) Does anyone have Win 7 64 bit and can tell me how to fix this please ? Thank you.

what version of Python? Blender 2.49b needs python 2.6 and Blender 2.5 needs Python 3.1.
In windows XP, you need to set an environment variable that points to the path of your python installation.

Did you ever find a solution to this? Nothing I do allows Blender 2.53 beta to find Python 3.1.

For every previous version of Blender I have just added the correct python directory to the PATH environment variable, and that works fine. But not for B2.53/python31.

I am on Vista 64-bit.

where did you install you phyton?
i once had this problem and my phyton was installed in C:\ program files\ phyton in sted of C:\phyton
maybe check that

I installed Python in its own directory, just like all the other versions of Python that I have. Also tried 32 bit python, but that doesn’t work either. Can’t seem to get 64-bit Blender to find any version of Python at all.

I circumvented the path issue in Win XP by installing python inside blender root directory ( i use the zipped version of blender and not the installer).

You have to use the exact folder name which python suggests during python installation, but you change the installation location to the Blender folder/directory.

You could try this on win7, might work.

its been a long time!!anyway im having the same problem with win.7 32 bit and python.
and blender 2.53 finding the installed python?any solution yet??:spin:

Same problem here. Vista 32, Blender 2.53, Python 3.1 installed in default location. . It won’t find the Python installaion no matter what I do. PYTHONPATH environment variable set, Python directory added to PATH variable, but no joy.

Edit:
Ok, update. Setting up PYTHONPATH and the PATH variable for Python 3.1 broke my Python 2.6.2 support in Blender 2.49b. I deleted these and Blender 2.49b had no problem finding the installed Python without them. Blender 2.53 cannot find the Python 3.1 install. What gives? :confused:

Also, I just noticed Blender 2.5 alpha 2 cannot find the installed Python either…

Edit 2:
From http://www.letworyinteractive.com/b/2009/12/common-blender-2-5-problems-and-how-to-fix-them/

jesterKing said:

  		[Dec 10, 09 at 15:33](http://www.letworyinteractive.com/b/2009/12/common-blender-2-5-problems-and-how-to-fix-them/#comment-395) 								If the screw-over looks anything like the screencapture, then  check its instructions how to fix.

From Blender 2.5 on you won’t need any extra Python installed, btw. Python 3.1 is fully bundled with the Windows versions of Blender, and it is preferrable to not have any other version pointed at by PYTHONPATH.
Otherwise, check drivers and such, to see if they are most up-to-date.

:smiley:

I have the same problem.
I’m working on Windows 7 64bit, i remove python and blender, and reinstalled python 3.1 first, and Blender 2.53 after (both for Win 64bit). When i start blender, it say something like "found boundeled python in: " and then the blender’s python default folder.

How do i set PATH variables in Win7 and Blender to get blender find python?

edit01: python 3.1 is installed in C.:\Python31\

edit02: i set PYTHONPATH as
C:\Python31;C:\Python31\DLLs;C:\Python31\Lib;C:\Python31\Lib\lib2to3;
In internet i foud that the last part should be “C:\Python31\Lib\libtk;”, or something similar, but i haven’t this folder, so i tried first without it, and than fith the most similar folder i can find.
Now blender show the traceback, ending with error in loading a DLL…

I had the same problem as you on Windows 7 64 bit and I managed to fix it by manually downloading python 2.6.2 for blender 2.49b. And before installing python 2.6.2 make sure that you delete the other version of python.

But i want to use blender 2.5, not 2.49, and to do this i have to install python 3.1.

I found that my error is in the ‘Lib’ python folder, in ctype file, blender tell me:
File "C:\PYTHON31\Lib\ctypes_init
.py", line 7, in <module>
from _ctypes import Union, Structure, Array
ImportError: DLL load failed: Impossible to find speficied procedure

No you don’t.

Like the post above says, Python 3.1 is bundled with Blender 2.5x versions onwards, pointing to another Python 3.1 install can cause problems.


http://www.digital-air.co.uk/

But every time i try to use some python scrypts (like wo0doo camera tracking or blendigo) Blender tells there are problems with the script syntax, or even crashes.

What can i do?

Use 2.49b

Blender 2.5 has completely rewritten the python API therefore all scripts need to be rewritten to be of use in 2.5x. You are probably using old scripts compatible with 2.4x only.


http://www.digital-air.co.uk/

So i don’t need to set PYTHONPATH to use fully Python 3.1? But is this way beause blender has it’s own full python 3.1, or what?
And now taht i need PYTHONPATH to use blendigo and indigo, i have to wait for these to be compatible with the new API?

In the new Python 3.1 there is a “lib2to3” folder: isn’t it what i need to use in some way?

p.s.: now i have insalled both Python 2.7 and Python 3.1, in C:\Python\Phyton27 and C:\Python\Phyton31, and my PYTHONPATH point to 2.7
C:\Python\Python27;C:\Python\Python27\DLLs;C:\Python\Python27\Lib;C:\Python\Python27\Lib\lib-tk;
but Blender don’t seems to look for Python in anyway, it tells onnly “Found boundeled python at…etc”
Is it correct?