HELP! Blender No Longer Rendering Smoke Dynamics?

Blender has stopped rendering smoke simulations for me. The smoke plays fine in the animation player but does not show up in the render. Or in some cases the smoke shows up but is frozen in a single state - no animation to the smoke. All static images render fine. (Blender Internal - CPU Render)

I think particle renders are gone too. I usually do not render particles. But when I test by turning render to “halo” in the particle settings, nothing shows up in the render. Even though the display settings get the particles to show up fine in the internal animation player…

I have been trying to fix it for days now. I ended up doing a total clean re-install of Windows and then installed only Windows updates and critical software. Re-installed Blender still has the same problem.

Again: Help! I am fairly technical and know PC’s. But I can not figure what is wrong…

What I did:

  • Installed Blender 2.66
  • The next render of my smoke simulation tests had this problem. (CPU Render)
  • Assuming it was Bender 2.66, I downgraded to 2.65. This did not fix the problem.
  • Opened a previous version of the smoke simulation which had been working. Same problem - smoke frozen.
  • Created a new very simple smoke simulation .blend file. This one does not render the smoke at all even though it shows the smoke animating fine in the internal animation player.
  • Completely uninstalled Blender, deleted all blendcache files, renamed the “Blender Foundation” folder in AppData. Rebooted and did a clean install of Blender 2.65. Same problem - animations still frozen.
  • Bad video card driver? Downloaded newest driver and re-installed. No fix.
  • Virus? Virus scans - two different anti-virus (AVG and Avast). Adware scans, Malware scans. Nothing found.
  • A few other quirky things had been showing up around then. Could Windows be corrupt? PC memory failing?
  • Tested PC memory. Downloaded some video card exercisers / testers. No errors found.
  • OK… Windows had been getting slow lately. Perhaps it is time for a re-install.
  • Total clean re-install of Windows. Re-install only needed software such as Firefox, Thunderbird, etc.
  • Restore my user documents including the .blend files.
  • Install Blender 2.65 which had been working fine.
  • Wha’ the Wha’??? Blender still will not render smoke animation. No versions of my files render the smoke animation. The totally new simple smoke animation blend file does not render the smoke. Another simple smoke simulation file just now created with the newly installed Blender 2.65 still does not render the smoke simulation.
  • Just for laughs I now downloaded the new Blender 2.66a and tried it. Still no fix.
  • I have now re-installed most of my other software onto the PC. The ones that were acting a bit quirky before are working fine now. As far as I can tell it is only Blender which is still messed up.
  • No where in any of this did any error show up in the Blender System Console.
  • All done with Blender Internal Render and CPU Render (NOT OpenGL Render).

I am at a total loss. I know I need to upgrade to a better computer and a newer version of Windows. But I just do not have the money right now. Although the old computer and Windows Vista were slowing down Blender before, they sure never caused anything like this. I need to get this art project finished and I sure don’t have the time to restart in something other than Blender.

I can not imagine what could be wrong. Multiple Blender versions and multiple Blender files would imply a system problem. But I have now done a clean installation and I know of no way Virus or Malware would survive a complete re-installation of windows reformatting the entire drive. I can not figure any video card failure which would cause problems for just Blender and no other programs. Plus no video card failures showed up on testing.

Please, please. My only hope now is someone very familiar with Blender internals has some suggestion what might be wrong and how to fix it.

Attached: (all in .zip format to get them into the forum size and file format limits)

  • Simple smoke test (Test Render

  • Simple smoke .blend file where smoke render which is not working.

  • Simple smoke .avi video file showing short render with no smoke at all (every tenth frame).

  • Original problem .blend file

  • Original problem .avi video file showing short render with no smoke at all (every tenth frame).

Both .blend files have System Info in the Text Editor.

Thank you,

Timothy Atwood


Test Render (105 KB)Error Smoke Emitters and Vortex .zip (581 KB)Error Smoke Emitters and (1.54 MB)

I’ve not read all your post, it’s too long to bother doing so.

Opened the Test Render Bug blend file.
Press Free Bake
Pressed Bake
In Domain Material Texture panel, in the Voxel Data / Domain Object setting I selected the Cube object.
Pressed render I get the attached image for frame 40

Whether that helps I don’t know.