Help! Boolean is Backwards!

Hey recently I’ve modeled this dragon for a personal project of mine… I have used the Boolean modifier for the claws and wings but recently I decided to add some cool spikes. But when I try to use the Union Boolean modifier it just doesn’t want to work and looks like this:
[ATTACH=CONFIG]443258[/ATTACH]

Any tips on how to fix this? I’ll put the file in the attachments.

Cannot see your image !

Check face normals are all correct and consistent

Here’s the Picture! Sorry I’m having trouble uploading the file (it is under the required size it’s just not working:mad:)… Anyway This is what it looks like…


And this is what it should look like…


Any Ideas? I’ve Checked over the mesh and it’s solid…

That’s not what Richard asked you to check…
Check the mesh for inverted face normals (they’re supposed to point to the outside). If you look at the mesh in “pure” solid mode (without that matcap) you can spot faces with inverted normals quite easily by their darker colour (or enable normals display, of course).

If the normals are flipped, Blender can’t tell the inside from the outside on those meshes, so any Boolean operation is destined to go sideways.

If you can’t upload the .blend file here, there’s always pasteall.

Hey sorry I meant to say the normals are good. Here’s the PasteAll link:

http://pasteall.org/blend/42596

Thanks for that by the way! I didn’t know that site existed!

The normals on the spikes are flipped. You just can’t see it because they also have unapplied, partly negative scale:

https://dl.dropboxusercontent.com/u/27650383/04-07-2016%2000-32-17.png

Select the spikes in Object mode and hit Ctrl-A > Scale. You will see that they immediately change color to indicate the flipped normals. Then Tab into Edit mode, hit A to select all and Ctrl-N to recalculate the normals.

After that the Boolean should work as expected.

Problem Solved! Thank you!