HELP! Cd-rom stuck in drive (problem solved, thanks everyone!)

Allright, so my laptop’s got a slith where you just put the cd in and it reads it. My problem is that the cd’s stuck!
It’s being prevented from being ejected by that little thingy, which woul dmean that the cd is being read. It isn’t.
How can I get it out?

Hope you can help


  1. Get a paperclip.
  2. Find a hole like this…
  3. Stick one end of the paper clip in there. This should pop the cdrom open. Try pulling the tray out gently and see if you can get the cd out = )

It’s not a tray, that’s the problem.
It’s a slith/narrow opening in which you insert the cd-rom.
I hope you understand what I’m trying to say?

a slot loader? is it a mac?
try holding down the mouse button as it boots.

Yes, a slot loader. Thanks for letting me know what it’s called :wink:
No, it’s not a mac. It’s a portable computer and runs Windows XP.
Here it says: “Cybermaxx ® and AMD Athlon, designed for Windows XP”

I’m gonna try your trick, knellotron.

Wish me luck.

i had the same problem…

stilll havent fixed it though

that sucks…

well, good luck = )

Knellotron, it worked! :smiley:
I held down the right mouse button and within an instant the slot loader responded…
Thanks man :wink: