Help,center bug for curves-->Confirmed in tracker=Bug

I have made an eyebrow, with one plane and many curves. When I select all, make a duplicate and then mirror things over the x axis, it all get scrambled…because each curve has its own center.

Does anyone has a solution or way to handle this?

http://home.scarlet.be/~matrix64/images/firstrender52c.jpg

well first I would re-center the curve centers around the new curve centers :o.

Have you tried the mirror modifier instead of duplicating and mirroring?

I’ve tried the following which should work, but its not - looks like a bug to me… :

  1. I select the plane, go into edit mode and select all of the vertices
  2. I then do shift-S and choose Cursor to selection
  3. Then I choose Center Cursor which brings the center of the plane to the cursor

at this point the center of the plane is set correct

  1. I then select each of the curves and choose Center Cursor to bring the centers of the curves to the cursor… and this does not work, which should not happen.

HELP

I remember that happening to me a few time and every time I figured it out eventually but it took me a while and I never wrote down what I did. Is it the case where you are clicking the centre buttons and the pink dot just stays where it is? Very annoying when it happens because it seems so logical that they should move. I remember clicking the button multiple times in frustration hoping that would somehow do something.

I just tested the duplicate on multiple curves with oddly placed centres and it worked ok for me. I put the 3d cursor in the centre (x=0), set the pivot to rotate around the cursor then duplicate and mirror.

http://www.geocities.com/dsch57035/blender/centrenew.jpg

This button works for me. (in object mode).

Its the same effect… mmmm but I noticed that it only centers the center in the x direction, but not in the Y and Z direction.

Please have a look in the top view, side view and front.

edit With another curve it doesn’t even center the X direction…

I set my curve to 3D, moved the control points around, then back to obj mode. hit center new, and it still centered it to the XYZ center point of the curves. Or are you talking about the mirror effect afterwards?

I quickly duped your setup with a few curves per brow, then mirrored it all. no problems!
http://www.geocities.com/dsch57035/blender/eyebrows.JPG

Yes, I know what you mean with the technique… but the “center cusrsor” doesn’t work as it should.
Currently I’m at work, when at home I’ll try to include a piece of the blend file.

osxrules, yes it is very annoying :frowning: … but the center does move, but not to the exact spot where the cursor is.

I’ve tested starting from a new blend file and actually it has nothing to do with creating a new blend or not.

If you add a new curve and try the center cursor function, it works.

However, it does not work anymore if you turn on the “3D” button for the curve and reshape the curve in 3d space and move the curve around a bit. If you try again after modifying the curve, then it goes wrong and the center cursor does not do its thing anymore.

bump - Is nobody able to duplicate this problem? I just want to know if it is a bug that should be logged in the tracker or if it is me not know a certain thing…

Yes, it seems it is a bug.

%<

Thanks all and Fligh %

I logged it in the tracker as a bug:
http://projects.blender.org/tracker/index.php?func=detail&aid=3772&group_id=9&atid=125

This Center Cursor was confirmed to be a bug:

Comment By: Ken Hughes (khughes)
Date: 2006-01-19 21:41

Message:
Logged In: YES
user_id=709

Confirmed. In fact, the code is explicitly setting the z
dimension to 0 in docenter():

/* Curves need to be 2d, never offset in
 * Z. Is a somewhat arbitrary restriction, 
 * would probably be nice to remove.
 */
 cent[2]= 0.0;

Seems this code dates back to the original NAN days.