Help exporting to udk - too many faces

Hey everyone, thanks for helping, I’m having a problem exporting to udk. I think when I apply a material, it applies it to all faces generated in the wireframe from blender. Now I want the wireframe to be complex, so I can sculpt it, but for the material/texture to encompass the entire side of the object (wood in this case). I’m exporting using .ase and all of my textures are tiled and in the udk material editor. Here’s some pictures, thanks a lot!!

object in blender -

object mesh in udk (notice all the faces from the wireframe are generating their own texture sample)

object mesh in blender for default square - one texture spans entire side

so sorry if I’m missing something obvious or am completely off, thanks!

your first object is not unwrapped properly. Apply seams and unwrap your object properly, this way, your texture won’t repeat as in picture.

With sculpt, it is necessary to retopoligze the mesh to low poly, unwrap it, get details of sculpt via normal,ambient maps and then export to UDK.

your mesh is simple rectangle , but looks subdivided a lot, without any details. its a waste of polygons.

try studying some examples of sculpting & unwrap from ( i suggest Damaged Pillar tutorial) and trying to export them to udk for better understanding.

Thanks so much for the help! Seaming as well as the smart uv mapping seems to work well with the exception of this one corner. Do you have any idea of what’s causing it? I can’t find any edges, faces or vortexes in blender that are sticking out or something.

By the way, I haven’t started sculpting at all or looking into it, just trying to get the basics working.
Thanks so much!

You’re working on ONE UV tile, therefore all the UV geometry has to be scaled inside the tile (Light grey area).
In the UV window, select 1 vertice on each island, excluding the bottom right one and hit ‘CTRL + L’ to select everything independently. Now just scale it down so the UV geometry is inside the tile.
Made myself clear?

By the way, why are you using so much geometry for a simple mesh?

Alright, I’ve scaled everything down and gotten the same result. I’m using a lot of geometry because I plan on sculpting it to make it not look so perfect, and to sculpt you seem to need vertices to move. I don’t know how many vertices I’ll need or if its even the correct way to make things look better, but I’ll find that out after I can make sure I can import things to udk using blender. Normal maps are good, but I’d like a little more detail.

Sorry once again if I’m missing something obvious, I’ve only had the software for a week or two. Let me know if you can think of any other reasons I’m getting this error. Thanks!

Ok, The thing is, you should sculpt it first. retopo it , unwrap and then export to UDK.

Also, attach your blend file for closer look (pack it with textures you want on your model).

First thing,why so many vertices for such a simple object?
Second thing,why are you using tris instead of quads?

block 1.blend (669 KB)

I haven’t had time to sculpt it, so here’s what I’ve been working with. As far as using triangles over cubes, I don’t know why they’re like that, I didn’t model this, my brother does that, I’m just the sculptor.

Checked your file. Here are the first things which you need to do.

In Edit Mode , Press ALT+J to remove all tris to Quads. Then Remove All the Extra Edges ( Ctrl+Alt+ Right Click to Select Whole Loop) then Dissolve the Edges (don’t forget to check “Dissolve Verts” too in Tools panel).

Basically, your UV Map is not correct, thats why your textures are not working correctly.

You also need a seamless texture if you want to scale the image. Check out the attached file, it has one wood texture packed into it.

Thanks so much for responding, your model worked absolutely fine, but whenever I try to dissolve edges in my file, I get an error saying “invalid boundary region to join faces”. How’d you get around this?

i haven’t received any errors. try dissolving edges one at a time.

sorry I haven’t been on in awhile, but I just got it working finally! Whenever I did dissolve edges on individual edges, it would just delete them, which was not ideal. Fortunately, ‘limited dissolve’ erased just the ones I didn’t need, and kept all the edge loops. I imported to UDK and the UV map was spot on, everything looks great. Thank you to those helping me! Let me know if there was a reason I had to do limited dissolve. Thanks again!