Help hiding pieces of mesh for weight painting

The video I just made is the best way to show what’s happening. I’m trying to do weight paints on my character which is all one mesh. Some of the mesh is overlapping so I need to hide bits of it to do the weight painting correctly. I hide the bits of the mesh in edit mode, go to weight paint mode, then turn on paint masking. Only one part of the mesh gets hidden for some reason and I don’t know why. From what I’ve been reading in multiple places is this is how you should do this, but it’s not working right.

The only thing I can think is you select first the part you wanna work in Edit Mode and the rest you hide. You can select the parts with L.

That’s what I’m doing, but it’s not hiding the stuff I want it to hide when I’m back in weight painting mode.