help, how to disable that an object is always on top in 3d view

Hello,

I am just starting out with blender and I encountered a puzzling problem today, probably by having clicked some shortcut I was not aware of.

The problem I have is that one of the objects in my scene is always “on top”, meaning visible 100%, even though other object would intersect or cover it. First I thought it is a layer issue, but I put everything on one layer and still I have one object that is always drawn in front or on top of everything else.
This concerns only the 3d views (perspective, camera, etc.), the actual rendering shows things as they should be, i.e. the object is not drawn on top of anything else, and other objects between my super annoying always on top object and the camera cover that object.

Anyone have a hint what setting I enabled by mistake? Googling didn’t yield any answers so far :confused:

Thanks in advance

Look in the object properties to see if you have selected the X-Ray tickbox.

I knew this was easy enough, if only you know where to look. X-Ray was checked, and unchecking solved the problem, thanks a lot! :slight_smile: