help! i seriously need some advice :(

ive been working on an architectural modeling project for 3 days , almost 4-5 hours each day, and i almost had all the basic modeling done until today…i tried to open the file and it gave me a “failed to read blend file” and my heart sank. when i tried to open it directly through the files, it would crash the program…i heard this may be due to memory issues, and my last progress may not be saved the whole way, but there has to be a way to recover the file! help!!! i seirously put soo much work into it… :frowning:

Have you tried copying it on a external usb stick or drive, and opening it on a more powerful machine with more memory? You can send it to me, if you like, and I will test.

Perhaps try a newer build of Blender. I had a similar issue once and I swapped Blenders and it opened for me. Couldn’t hurt any I guess.

You have a few recourses:

  1. The .blend1 and .blend2 files saved by your .blend. It is a stack that pushes every time you save. Rename them to .blend and see if it works.
  2. The File > Recover Auto-saved mechanism. When you pull it up, be sure that detailed view is on so you can see the date.
  3. Start doing [Ctrl+Shift+s], man! The “Save As” dialogue has a little “+” you can click to increase the number. I do this before every significant change, maybe once every 3 hours at most.


Can you Append your objects when you start a new .blend?

I have been working on the file for months and 6 hours a day and I have put a lot of work into it. I open the file and get "failed to read blend file, file name ",“Incomplete” I have 5GB memory and a good laptop I don’t think its a memory issue. My file is corrupt and I want to recover it.