Help in a project! Render is doing subdiv

Hello! This is my 1st post here, as a computer engineering student I’m creating a small project with the blender and as I write, I’m not a very experienced user, just the basics mostly. What took me here is because I’m facing a ‘huge’ problem which I can’t seem able to solve and I can’t find anything on web for it. I’ve created a simple car model (which took me a LOT of time since I’m a newbie in this) and when I use the render preview for it, it appears all subdivided like if I added a subdiv surface modifier to it (which I believe I don’t) at least I don’t remember to add it or even more, apply it. I’ve already tried to open previous backups and all seem to have the same problem. Please don’t tell me I’ll have to start all over because this took me several days of work and I won’t have tim to do it again. There must be something that is causing this. I’ll send both pictures, the first one is the mesh view and other is the rendered one. Thank you!! I’ll be very thankful to anyone able to help me out with this.


Attachments



The renderer only renders triangles. If you have faces with > 4 sides then you have no control,on how they are triangulated. They may give satisfactory results or a complete crap result. You have moved that decision from yourself to a computer algorithm which doesn’t care about the final result.

For non planar faces you will see triangles even for quads but to have more control over the shading see https://www.blender.org/manual/modeling/meshes/smoothing.html?highlight=shading

So, for a completely noob like me is there any possible solution for this? This car is all made from vertices extrusions and then pressing F to fill every face I wanted to create. That’s how I found easier to design it, with the freedom of vertices. But it’s driving me nuts why this is looking like this. How can I solve it and how can I prevent it? Thank you again!!

If you want a flat shaded render that doesn’t triangulate, turn on auto smooth in mesh properties, and set the angle to 0.

It does look like an issue from using polygons with more than four sides, like @Richard_Marklew says.
To fix this, you have two options:

  1. Divide each polygon with 5 or more sides into quads (“quads” is slang in 3D modeling for polygons with 4 sides). In vertex select mode, select two vertices that are corners of the same polygon. Then, press the “J” key. That will divide the polygon by creating an edge that connects the two vertices. This simple method should go a long way in improving your model. Cleaning up geometry can be very difficult, even for experienced modelers. But, you can probably “clean up” your model a lot by simply doing that.

  2. You can “retopologize” your mesh. That is where you recreate your mesh. Usually it is when a 3D sculpt (with very messy topology and many polygons) is recreated with clean topology and with as few polygons as necessary. Your case is unconventional, but the concept still applies. Here is a link that talks about it.
    http://blog.digitaltutors.com/retopologize-nine-times-faster-shrink-wrap-modifier-blender/