Help in UV Unwrapping - Relax Map

I was trying to relax my uv map. but when i select a vertex on an island, the other vertex from another island also moves. i already tried deselecting everything by pressing A, but the other vertex is still affected.

This is one of the weirder quirks in blender. Basically those vertices act in unison because they are the same single vertex in the mesh. One way to work around this is to go to (In UV window) face mode. Select the things you don’t want to edit, hide them, do your vertex edits, unhide.

I don’t remember right now was there less cumbersome way to work with this.
Hm sadly still seems to work the same way in 2.8, too.

I’m not 100% sure, but can you not select the island you don’t want altered in face select mode, hit H to hide it, switch back to vertex mode and do your stuff? Then Alt+H

Deselect the button “keep UV and edit mode in sync” in the UV Image editor menu:

000

When you activate this option, you are telling Blender to select the vertices phisically on the mesh when you select it on the uv’s.

In uv’s, you can make seams and have 2 vertices, but in mesh can be only 1 vertex, thats the reason when you select a vertex with a seam in the mesh, you are selecting 2 vertices on the uv’s.

If you uncheck that button, you will be able to move only one vertex on the uvs, but you will have to select the mesh to see the uvs of course.

If you want to relax the uv’s, you can do it with the UV Sculpt tool, pressing Q inside the UV Image Editor window, that way you can protect the borders or unlock it in the left menu (T).
0001

is it normal for another vertex to be moved? or have i accidentaly pressed a key? because in some parts when i click 1 vertex, another vertex gets also highlighted. 2019-03-06 12-33-16.flv (3.5 MB)

i tried unchecking the button below but still, it’s selecting many vertices when i try to move only 2019-03-06 12-51-21.flv (3.1 MB)

You are only moving one vertex. That vertex can exist more than once on a UV map though. They can be on the same of different UV islands. Think of a standard map of the world. Every point along the right hand edge of the map is also a point on the extreme left hand edge.

Like 3Rton said: hide all Faces you don’t want to move, move the Vertices and unhide the first Faces again.

How do I do it? when i click the vertex, and press L and inverse select and hide the other islands, the shared vertices also gets hidden. is there something wrong with my model?:disappointed_relieved:

2019-03-06 19-36-49.flv (3.8 MB)

guys, i just found the fix. it’s in the Shared Vertex Option. You just have to change it to Shared Location. now i feel stupid :rofl:

2019-03-06 20-09-30.flv (2.5 MB)

so if i move a vertex in one island, the same vertex in the other island gets move right? aww i thought there was something wrong, or i accidentally pressed something. is it the same in 3ds max? coz i only had tried a few times in max but i don’t remember. but the relax feature was useful. i hope blender had the same feature.

You can do it two ways:
• in Face mode you can freely move polygons without affecting the UV vertices of neighbour isles, and you don’t need to hide anything.
• In Vertex mode, by disabling the sync with the 3d viewport (as shown by @DarkDogma3D) an icon appears on the header which let you choose between three modality:
Schermata
Shared Vertex behaves as in sync mode, that is what you don’t want;
Shared Location allows to move the vertices of isle margins without affecting the shared vertices of other isles, that is what you want;
Disabled allows to move each vertex of each polygon to separate contiguous faces.

1 Like