help installing blender on Linux Mandrake computer

hello all,
i am trying to install blender on an old pc that i recently converted to Madrake 10. i am following these
directions, which are the same as the ones in the blender 2.3x manual. i am trying to install v 2.32 from the disk that comes with the manual. after completing most of the instructions, the final thing to do is: "To start blender just open a shell and execute ./blender, of course when running X. "

everytime i do this, i get the error message
“./blender: error while loading shared libraries: libstdc+±
cannot open shared object file: No such file or directory”

i am really new to linux (3 days) and have no idea what to do now. Can anyone help?

go into the package manager [in the mandrake control center] and instal libstc6

of course, that is iirc, last version of mandrake I used was 8.2

thanks for the suggestion, but there is no package available (from the installation) called libstc6

oooh, one more thing. the version of linux that i have (mandrake 10) says i586, while the blender distribution says i386. could this be the problem? is there anyone here who has gotten blender installed successfully on mandrake 10? if so, how?

I do not have Mandrake 10, but I do have 9.1. In 9.1, you do not install Blender, you merely extract it. Once you have extracted it to a folder, then you should be able to run it just by clicking on it. If it will not start up, then go to the folder where it is and press Ctrl + T to open a terminal at that location. Type in ./blender to run the application. If it does not start, it should give you an error message that will give you a better idea of what is going wrong.

i just tried doing exactly that, and it gave me the same error message. im wondering if it would b a good idea for me to switch to v 9.1.

off-topic: just wondering how u (or anyone else) like 9.1. the feature that i need most is the ability to connect to a wireless network with i NIC card. do u know if i can do that without too much trouble on 9.1?

extra thanks

Did you try downloading the static package? I think that it includes some of the libraries that Blender needs to run. I am not certain what packages you need to install from the installation disc to run Blender. I usually go through and do a manual install. Just a thought: have you installed the package that includes the source code for the kernel? I do not know too much about the technical aspects of Linux, but that might be helpful. See if you can figure out why Blender crashes; see if it tells you in the console what it needs. Then, see if you can find and install that.
I tried 10, but I like 9.1 much better. It is my opinion that in Mandrake 10, they dumbed-down the user interface. I was, in general, rather unimressed with it. I also tried 9.2, but, for some reason, it did not work. So I have 9.1. It may not be perfect, but I like it. I do not know anything about networking under Linux. I would assume that if you can get it to work under 10, you can probably get it to work under 9.1, though.

is 9.1 available for intel, or only power pc ?

I am running it on a 525 mhz Intel Pentium III.

thanks for all your help, i ended up switching to SUSE 9.1, for a couple of reasons. now, blender works fine, tho kinda slow. thanks

Sounds like you found a workaround. But if anyone else runs into this problem, here are some suggestion from a former Linux user (Mac OS X user now).

If a shared library (.so) is missing, do “ldconfig -v | more” to get a list of all the shared libraries and versions installed. For example

Alternative 0 - Use the Static build! (possibly no shared libraries required)

Alternative 1 - As z3r0 d, you can go to the package manager (RPM or whatever) and try to locate/install the correct binary package.

Alternative 2- you could find the source and make/install the package. For a big C library that can be a difficult compile/install.

Alternative 3- Sometomes an app is compiled against a shared library that exists on your system, but was named in a non-standard way on the person compiling’s system. If the major version is the same, then sometimes you can get things working by a total HACK: make a symlink with the correct name, then rerun ldconfig. For a made-up example:

su -
cd /usr/lib
ln -s libstdc+±
ldconfig -v

Now the system “thinks” you have the shared library named libstdc+± Again, use that one at your own risk!