Help Me Build Blender MingGW-64 Windows 7

On Windows 7 64 bit.
Using CMake 2.8.8 win32, MingGW-64 (version used by bf ) , TortoiseSVN 1.7.7
Following the guide here

Folder structure is as follows:
C:\opt\BlenderSVN\blender
C:\opt\BlenderSVN\lib\mingw64
C:\opt\BlenderSVN\cmake-build

cmake-gui fails on configuration with the following error:CMake Error at CMakeLists.txt:1453 (message): Apple and Windows require pre-compiled libs at:‘C:/opt/BlenderSVN/blender/…/lib/mingw32’
How do I tell CMake I wish to build a for x64?

Thanks.

###Edit###

Here’s the full output from CMake:

The C compiler identification is GNU 4.7.1 The CXX compiler identification is GNU 4.7.1
Check for working C compiler: C:/opt/mingw64/bin/gcc.exe
Check for working C compiler: C:/opt/mingw64/bin/gcc.exe – works
Detecting C compiler ABI info
Detecting C compiler ABI info - done
Check for working CXX compiler: C:/opt/mingw64/bin/g++.exe
Check for working CXX compiler: C:/opt/mingw64/bin/g++.exe – works
Detecting CXX compiler ABI info
Detecting CXX compiler ABI info - done
Performing Test SUPPORT_SSE_BUILD
Performing Test SUPPORT_SSE_BUILD - Success
SSE Support: detected.
Performing Test SUPPORT_SSE2_BUILD
Performing Test SUPPORT_SSE2_BUILD - Success
SSE2 Support: detected.
CMake Error at CMakeLists.txt:1453 (message):
Apple and Windows require pre-compiled libs at:
‘C:/opt/BlenderSVN/blender/…/lib/mingw32’
Configuring incomplete, errors occurred!

Nevermind.
Scrapped CMake.
Using Scons
Works a treat.

How do I tell CMake I wish to build a for x64?
just add mingw64 to your systems path, and cmake will now that you are building form x64, also make sure that mingw32 is NOT in your systems path.

thanks for the effort, bat3a.
Beginning to think that no one cared… :stuck_out_tongue:
mingw64 already in the system path.
That wasn’t the issue.
Had to add the WITH_MINGW64 switch in cmake.

Upon closer inspection, this information is presented in the build docs on the blender.org wiki, but it is presented out of order and I had glossed over it.