Help me pls

I need help. Yesterday when I import an obj file (without legacy), it was successful. Today, I import an obj file (without legacy), it wasn’t successful. Then I used legacy and succeeded but the size wasn’t normal, it was very small and I can’t scale it up.

Can you scale it by using the sidebar (n key) and typing a large number under “scale”? After that, you can hit “frame selected” in the viewport to focus on your object, wherever it is.

Bear in mind that a very small or very large object might not be visible due to clipping settings in the viewport. Change the range from very small to very large to see tiny and huge objects too. The clipping settings are different from the camera object view clipping settings.

Blender will always have scaling issues upon importing, because it’s measurements are off x 10. Usually you have to scale down rather than up though, so it might be an issue with the particular model you imported.