HELP ME!! Yafray in Blender driving me crazy.

I need some help learning how to composite using Yafray as a render. All documentation I have found refers to rendering/compositing with blender.

I am finding that the Blender buttons don’t behave the same when using Yafray. For instance, I cant get my textures to refract through glass.

I have posted my Blender file at
in order to assist anyone willing to help.

apparently it can’t show refraction of a textured plane since it’s not a 3D object. I’m no pro…I don’t know much about texturing and coordinates. Maybe play with the way the image texture is mapped onto that back plane. I tried your file and verified your image. Then I put a cube behind it, and refraction was given properly.
Good luck

I didn’t mention this at first, but I was able to get refraction with my textures through different mappings (Map Input). I chose to use the “Win” for the map input because it placed my picture/texture in full view.

The other “map to” options gave some kind of refraction, but the picture/texture was stretched and distorded.

I also tried the paper view in the world options and got rid of my texture plane. This doesn’t seem to function with the Yafray renderer and only displays the world image at a large and distorted size.

I have tried everything I can imagine with no luck. It is important that I get this compostition stuff down as I am an engineer and visualization is what is important to me (I do my modeling in Solidworks).

I have come to a point where I am going to check out Pov-Ray and VirtualLight.

Any COMPOSITING Guru’s out there???

Put a real plain behind it. The world texture works different in Yafray than internal renderer.

I am not sure what you mean??? I am only using the world for lighting in this case.

The example shown already has two real plains.

One for the background and one for the ground (so the orb can cast a shadow/caustics). Refraction doesn’t work through the orb when mapping the texture using the “win” button.

However this is the only button that gets my texture exactly in the window.


I’m no expert at it still, but try using only one plane for the image, then curling the back side up so that the same image/plane is used for the ground and background. Very difficult to get your coordinates set right though. I was playing with your .blend yesterday, but couldn’t get it right. I don’t understand all the different coordinate systems and texture inputs yet in blender.