HELP! My 3D model wont show up in video footage

After following tutorial on youtube about tracking video footage and add 3D model in it. i followed it step by step. nothing is diffucult and confusing until it came to the composition step.
and then, my 3D model wont show up in the video footage.
this is the only Blender feature that i still stuck on. modelling, scuplting, painting, and rigging is not so much difficult to me.
any simple instruction will be much appreciated.

And you are working in the compositor (not video editor) and have use nodes enabled and use some noodleing to do something and… Maybe be more precise about the tut and your setup?

this is me, the one who made that topic. i use my second account because another account is on another laptop which suddenly shut down because battery is low, so i use another laptop.
so, regarding my previous question, here is the result :slight_smile:
link to viewport :


link to render result :

the footage doesnt show up. sometimes the opposite. i dont know what happen

Hmm no links here. (Maybe to new account for links?)

composition :

You can’t use any alphao verlay when you render the background grey !! Use Render Properties-> Film → Transparent.

can you fix it for me, please?
i will send you the file then

here is the link : https://firestorage.jp/download/cc168b6da4c2055387e32b460f06961deee5effbrtyve4ie1l25ttx8ujmf

Did you even check my answer? Your rendered background seems to be not transparent, so you can’t mix it. (You ground plate also need to use a shadow catcher.)

wow! i just did what you said and boom… it’s magic bro!
but, how can i hide the ground?

Thats what a shadowcatcher is for. It catches shadows but is itself not visible
If the renderer is set to cycles theres an option to turn an object into a shadowcatcher under ObjectProperties->Visibility->Shader Catcher

i looked up on youtube about shadow catcher and follow the tutorial.

but the result is the ground is still visible.

if i can master this step , i promise to make something about both of you because of your helps.

IDK why so compli


cated?? This is just a cube on a plane with Object Properties → Visibility → Mask: Shadow Catcher:

dude, it took me few hours to figure out what you’re talking about shadow catcher. and then i finally found out that it was in Cycle because i didn’t find it in Eevee.
xxx
anyway, i finally found the way to render it in Eevee

Oh i thought this tutorial you was speaking of uses cycles, because those composition things mostly wanna use cycles because of the better shadows AFAIK. (On the other side you haven’t mentioned which tutorial… see ? :wink: Always give information about what your are following and what you tried to change.)

:open_mouth: I mentioned that in my post, just ask sooner if something is unclear.
So as you’re now on it. There are some more parameters that have an influence on how and if the shadow catcher shall interact with the light calculation for specific terms. So turning them off keeps the shadowcatcher from having influence on your trains shading/lighting.

effects