HELP🩺, Mysterious Blue Dot doesnt go away!

Hello there,
I have tried everything But this mysterious blue dot doesn’t go away in 3D Viewport

No, It is not an Annotation Mark,
Not a vertex though looks like that but not a mesh
Hiding Overlays doesn’t help.

I have tried almost everything, but I cannot seem to figure out this thing.

Likewise, I would be very thankful :pray:If someone can look at this file and remove this dot. :mechanical_arm:
startup.blend (1.9 MB)

I opened file in blender 3.1.2 and don’t see anything besides cube.

Could be version related? Are you using extra addons or scripts?

1 Like

No mysterious blue dot here either:

1 Like

3.1RC here and nope no dot…the only time I have seen that is with the add-on Sketcher, which is very new and in Beta? Did you get that addon?

1 Like

Yes,I am on same version as well and that what I thought that It could be because of the addons :sob:, Any Idea how do I figure out which addon is causing this ?? :pray:

1 Like

Yep, I tried diasabling the addon but still same. Maybe Some other addon which I dont know how to find out :pensive:

Thanks for confirming.

It should have vanished if you selected Delete sketch…see if there is a Sketch in the addon and hit the pencil icon…that lets you edit the sketch…then you can select delete sketch…

1 Like

No It is not beacuse of Cad Sketcher Addon. I have Inspected well.

OK. I Figured out something. What is wrong is not in the Startup file but in the UserPref file, Perhaps my UserPrefs file got corrupted beacus eof too may addons (many being under dev).
I am still trying to figure out, which Addon is the Culprit :imp:

no no leave the addons where they are!

is hidden in the blender preferences or vieweportsettings!

tomorrow i can tell you how to turn it off

Delete your annotation layer.

or you can hold “d” and erase the dot with your right click.


Only enable addons you are actively using. It’s really easy for things to go wrong with too many cooks in the kitchen.

Hi, You might have not read it, But I alredy mentioned it is not an Annotation mark !. There ae no annotation layers in the scene. It has to do with some addon I suppose

Agreed. I even disabled all community addons but the dot was still there.
I had finally reset my userpref and now using as few addosn a spossible. Perhaps the wip addons I shud use them in a portable second build.

It looks like an origin point so maybe just an object without a mesh?
How many object do you have in the outliner? Does selecting them one by one highlight the blue dot?

I also do not have that when i load your startup, version 3.1.2 ,
are we talking about this?! :

there is also a refresh-problem!
so you may think that this setting does not change anything, I always have to orbit a bit then the view
port is refreshed



OMG, THIS IS IT !! :raised_hands::clap::clap:You are the real MVP man. This nastly little setting had been like itch at an unreachable position. Thank You so much for the Help ! :pray:

I have no idea How this setting got turned On automatically and what you showed in the gifs is exactly right.
Perhaps a BUG in Blender that needs to be reported.
Thank You so much !
Have a Nice Day sire :rainbow:

1 Like

Done! :+1:


Still exists in Blender 3.2.2. (…but turning off “Show Navigation Guide” in prefs does make it go away)

macOS 12.5 Monterey
built-in Intel Iris Graphics 6100 1536 MB