Help needed for rendering very large image

(halfgaar) #1

Hi,

I have a project which I want to have printed poster-sized, and for that, I need a high resolution render (6000x4000). The problem is, when using a lot of compositor nodes and rendering at high resolution, blender has this bug which causes it to crash (on my machine) because of the huge amount of memory required by the compositor buffers.

I have an Athlon X2 3800+ with 2 GB of memory. I was wondering if there is someone with 4GB (or more…) of memory who is willing to help me out on this one, and render the image for me, assuming it won’t still crash. You’d need to download a 60 MB file, and the render will probably take an entire day… The blend file is made with version 2.44. All you need to do is open the file and render. It is already set up to save the rendered result, and all that.

You can use the blend and texture files for anything you want, provided it complies with the creative commons license by-nc-sa-3.0. Normally I would put it up for download for everyone, but because I pay per MB, I’d rather not have people downloading that 60 MB file all the time (provided there would be interest, that is…)

0 Likes

(SKPjason) #2

There is a python script on this page:
http://alienhelpdesk.com/python_scripts/really_big_render

This script allows you to render “chunks” of a very large image (you put them together in Gimp, Photoshop, or other image editor).

0 Likes

(hessiess) #3

i gave a q6600 computer, good enugh?, but i only have 1 gig of ram, its running ubuntu linux, dont mind using it for rendering overnight

0 Likes

(MrRage) #4

If the chunking method doesn’t work I have 4gigs on this box but I think I’m restricted to 2gigs per process (32bit OS). If I had a 64bit OS that would be diffrent

0 Likes

(halfgaar) #5

The chunking script says it can’t find the camera… When I remove the error check in the code, it says this in the console:

scene.getCurrentCamera() deprecated!
        use scene.objects.camera instead
Traceback (most recent call last):
  File "ReallyBigRender.1.py", line 161, in PrepScript
  File "ReallyBigRender.1.py", line 63, in GetSettings
NameError: Camera "Camera" not found
Traceback (most recent call last):
  File "ReallyBigRender.1.py", line 161, in PrepScript
  File "ReallyBigRender.1.py", line 63, in GetSettings
NameError: Camera "Camera" not found

Can that script even handle the compositor? I wonder if all it’s effects will be seamless.

i gave a q6600 computer, good enugh?, but i only have 1 gig of ram, its running ubuntu linux, dont mind using it for rendering overnight

With only 1 GB of RAM, I don’t think it’s gonna work.

If the chunking method doesn’t work I have 4gigs on this box but I think I’m restricted to 2gigs per process (32bit OS). If I had a 64bit OS that would be diffrent

If no one with a 64 bit machine and OS can help, we could give it a shot.

0 Likes

(halfgaar) #6

For the record, the “really big render” script won’t work. The script moves the camera around and renders individual parts, but my compositor setup won’t work properly like that. Some of the effects only work if the entire frame is rendered as one. One of the artifacts was a black bar at the bottom of each tile, because of a translation effect of the background layer.

0 Likes

(jaycun) #7

here’s an idea…

instead of doing it all in one go…try this

  1. render the raw image and save it to an HDR format (OpenEXR, Radiance, TIFF, etc)
  2. Load the image into compositor
  3. Render
0 Likes

(ebow3d) #8

I don’t understand how you got to this resolution. You could print A1 size posters @ very high quality from 3000x2125 or 4000x2835. The bigger the print, the lower the dpi required.
After many years of experience, I’ve learned that nobody at print shops know the first thing about image resolution.

0 Likes

(halfgaar) #9

here’s an idea…

instead of doing it all in one go…try this

  1. render the raw image and save it to an HDR format (OpenEXR, Radiance, TIFF, etc)
  2. Load the image into compositor
  3. Render

There are a couple of render layers I would need to save into files then, but I guess it would be possible. However, I don’t think it’s gonna make any difference. When the compositor pass begins, the renderer is already done and it should have released all it’s memory. There is no point in keeping the subdiv meshes and oct tree in memory at that point.

I don’t understand how you got to this resolution. You could print A1 size posters @ very high quality from 3000x2125 or 4000x2835. The bigger the print, the lower the dpi required.
After many years of experience, I’ve learned that nobody at print shops know the first thing about image resolution.

The bigger the print, the lower the DPI required? That seems kind of backwards. I would like an image that looks as sharp as a print of a normal digital photograph, also from up close. The resolution I chose results in 200 DPI at 50x75 cm, which isn’t even very high. But, I’ll keep it in mind; perhaps I’m overdoing it.

0 Likes

(Dan) #10

Any idea how many hours it would take on a q6600? (4 x 2.4ghz cores) It’s just that I haven’t really broken my system in yet, and don’t have temperature monitoring figured out yet in linux.

0 Likes

(halfgaar) #11

I couldn’t say. Still several hours if not a day, I would say. How much RAM do you have, and is your OS 64 bit? Do you want me to send you a link to the file?

I sent a link to MrRage as well, so I’ll await his reply with the results before I sent it to you. Otherwise, one of you will be rendering for nothing…

0 Likes

(Dan) #12

I have 4gb of ram and the OS is 64bit Fedora. I’ll give it a try if it doesn’t work out for MrRage.

I got lm_sensors working now, and realised that my cpu fan was spinning up to a maximum of 900 rpm only, when its capable of 2500 :mad: Only thing is, to get it to run at 2500, I have to disable all fan controls, so it runs at that speed even when idling hehe. Gotta find a way around this lil problem.

edit: ok, cool I have it sorted out a bit better now. Just enabled PWM in the bios so the fan sits at around 1300 rpm on load and the cpu temp is no higher than 55C. So I should be able to handle your job I think, if needed.

0 Likes

(halfgaar) #13

I don’t think MrRage is rendering, because the file hasn’t been downloaded, according to my logs. I’ll send you the link in a PM, and let MrRage know he can wait.

I’m rendering myself with an oct tree size of 64 BTW. So far so good, after about 4 hours, but that could merely be caused by the fact that a small oct tree increases render time, and therefore delays the point of crash…

And about your fan, did you try running pwmconfig? In any event, Blender doesn’t use the video card for rendering, so it won’t get cooked because of this.

0 Likes

(Dan) #14

See my edit :slight_smile: And it was the cpu temps that i didn’t have monitored. I’ve enabled pwm in the bios now for the cpu. I’ll take a gander at that file now. Sounds Dune related :eyebrowlift:

Ok, I’ll have the file in a few mins. It’s all good to go - anything to double check, or just press render?

0 Likes

(halfgaar) #15

Sounds Dune related

It is :). There is a link in my first post, so you can see what you’ll be rendering. I can imagine you don’t want to waste time on rendering crap, so you might want to take a look at it first and decide if it’s worth it :slight_smile:

0 Likes

(Dan) #16

I’m getting an ‘unable to open’ error.

Edit: Never mind. It opens now. I had to open it from within Blender rather than double clicking on it. Ok here goes… I’ll be awake for at least another 6 hours tonight. I see the OSA is set to 5 - no need for it to be higher?

0 Likes

(halfgaar) #17

Higher OSA levels have often little effect, in my experience. But, in this case, I just forgot about the setting. Level 5 will do, otherwise it will take even longer…

0 Likes

(Dan) #18

Yeh it’s looking ok so far. Hard to tell how long it will take in total. It’s on part 34 out of 64 on what I presume is the first pass of several.

0 Likes

(Dan) #19

Hey man, I came back to the pc and blender had closed - no sign of the image in the tmp directory or the //render/frame location that’s specified in the blend, so I can only assume that it crashed :frowning:

Edit: I just rendered it at 3000x2000 which only took 28 mins. I’ll give it another try at 6000x4000. Should be possible.

0 Likes

(halfgaar) #20

I think trying again at 6000x4000 won’t be successful. What happens when you render at 75% (use the 75% button with the resolution still at 6000x4000). Perhaps that will have to make do.

The final frame is not called frame-x BTW. The node setup saves a file called big-render100 or something in //render. That’s the one I want.

0 Likes