Help needed removing doubles

Hello everyone,

and thanks for your time viewing my question.
Sorry, if my post is disorganized, but I omitted links as I think new users are not allowed posting them.

I am following blenderguru’s tutorial on modelling and making an anvil. I made the base of the anvil, then added a cylinder and used boolean modifier to cut part of the base of the hammer away.

Then I tried to make resulting polygons quads as demonstrated in the tutorial. Knife tool worked as it should, but grabbing the edges with g g and dragging over to the nearest edge didn’t result in any “hits” when I then used remove doubles.
Also, someone noted in the videos commentaries, that one could also use “dissolve edges” or vertices, but that also resulted in disaster, lot of faces disappeared.

There must be something fundamentally wrong with my mesh, but I can’t understand what it is…

I am trying to attach my blend file, boolean is ready for action and then I try to grab the edges resulted.


anvil.blend (486 KB)

I can’t check the blend file right now, but if your sure there is doubles but the remove button isn’t catching them it’s likely that they are not perfectly on top each other. When that happens you have to increase max distance. I forget exactly what it’s called in blender, but after you press remove doubles look in the side panel (t) and there will be a new option to change the allowed distance of doubles.

Select the object, ctrl+A -> scale. Edit mode, select all, W -> remove doubles. Could also then do ctrl+N to recalculate normals outside. In that order.

Applying object scale transfers the scale multiplier to the mesh dimensions and then resets the scale, then the mesh dimensions match what you see in the viewport. Remove doubles work on the selection and within set merge distance, which now match what is shown in the viewport. Then calculating normals can be done on the mesh that doesn’t have doubles anymore.

Thank you for your efforts, but I still can’t seem to get it right…
I did the scale applying and tried to adjust the threshold for removing doubles, but it doesn’t work

Well, at last I seemed to get it work.

I needed to have a tap in the “Unselected” box below the Merge Distance. Thank y´all for your help!