Help needed with Cameras, HELP!


(Fred_Pyo) #1

Look, I’m about to upload a little something I’ve been working the last couple of days, but I have a little problem with the cameras, this is the problem:

I have 3 Cameras:
1st Camera:
Goes through a corridor, path done with IPOS… and ends up looking at the character…

The character does some animatios, and then sends a message.
This message makes the 1 camera to End it’s existense and sets the second camera as The Camera of the scene… Good good… the switch is done… it all works…

2nd Camera:
It activates and moves from the final positon of camera 1 to the position of camera 3, once it ends it movement, another message SHOULD switch with the 3rd camera and make the 2nd Die…

BUT, it doesn’t happen… :x

The deal, I think, is that this 3 camera is vertex-parented to the body of the character which is parented to it’s armature, which is… created and inserted into the scene before the 2nd camera is supposed to die. And the engine doesn’t seem to recognize this 3rd camera… AND I NEED TO SWITCH TO THAT LAST CAMERA…

Is that the problem? That the camera originally doesn’t exist in the layers selected? Any solution?

I Need the camera to be parented to the body kuz it has to follow it ALWAYS… always always…

If I didn’t make myself klear, just shout…

-Thanx


(wiseman303) #2

try adding an always sensor to camera 3. turn pulse mode off.
conect this to an actuator that sets camera to camera3, and maybe send a message that deletes camera2.