Help new problem with GLSL alpha texturing?

How do I make this grass texture alpha in GLSL?
Here is the file to see if anyone can tell me how to fix it?
Grass2.blend (434 KB)
Saeblundr’s explanation worked but it doesn’t work for an image with a black background.

What is below doesn’t matter that was my old problem but I didn’t know how to get rid of it.

Attachments


TREE.blend (424 KB)

In MATERIAL panel turn on TRANSPARENCY > Z Transparency = 0.000
In TEXTURE panel check PREMULTIPLY under IMAGE, and check ALPHA under DIFFUSE in INFLUENCE

Thank you saeblundr