Help? Only 1 Render Layer will render

Hello Folks,

I have Blender 2.7, and as a backup 2.69. I have three render layers, each with only one or two low-poly objects. I’m rendering in Blender Internal (yes, I have my reasons). Hooked all three render layers together with Alpha Over nodes at “fac” 0.5 and then the whole shebang goes to to the composite node. The setup is simple and classic, and the viewer node displays all three layers in perfect order and harmony.

Then I render it as a still image and only the 2nd render layer renders. All three render layers have exactly the same settings, including “combined.” All three scene layers are checked, and the camera and light are checked into all three scene layers. If I move around which object is in which render layer, Blender still renders only the object(s) in the 2nd render layer. Same if I move them around in the scene layers.

It’s times like this that I wish I had hair on my head to tear out LOL.

It’s times like this that I wish I had hair on my head to tear out LOL.

We’ll your not helping anyone elses coiffure. No blend file to review !

I suppose we have to guess what your scene looks like, how you’ve set up your render layers, what render settings you are using.
Wouldn’t it be easier on everyone if you just take 10 seconds and supply a blend file with your post

Sorry, my bad. There should be a .blend file attached to this reply.


holographic shopping console.blend (910 KB)

Your blend file contains none of your textures.

When I add some textures all layers render but we have no idea what your textures are !

Before saving your blend file you need to pack all your textures in it using the File / External Data menu

You mean it gets the second in final composite? That’s because you’re combining the layers with alpha over node but there is no alpha transparency on your rendered layers.

Render properties -> shading -> alpha: transparent, or disable sky option on each render layer you want to have alpha transparency.

Here it is, packed. Thank you for your patience.


holographic_shopping_console-p.blend (1.9 MB)

JA12, when I render it briefly flashed each layer, but when the render is finished only the 2nd render layer is visible in the final image. I have tried and just tried again unchecking “sky” for each layer in Scene/Layers, and also changing “sky” to “transparent” in Render/Shading/Alpha:

Didn’t work, same result. I also tried used mix instead of alpha over nodes. Didn’t work, either.

The curious thing is, the viewer node displays all three layers properly in the viewport. The only problem is the actual render.

Right, wasn’t only about the shading but will be when foreground elements are put on top of the background with the factor of 1


Yes, mix node in mix mode needs the alpha transparency too. Although, since the backgrounds are completely black (value of 0), it would be possible to add them

Bottom left: result from mixing layers without alpha transparency
Bottom right: result from adding them

This works when adding color values over 0. If it had color values overlapping, that could be an issue with that blending mode

Bottom left: mixing layer with alpha transparency over another using mix node
Bottom right: adding two layers with overlapping color values

I’ve tried changing the Factor in both of the alpha over nodes in different combinations. 1.0, 0.5, 0.0, 0.6, doesn’t matter. No effect.

I switched the combining order but still, changing the values should have an effect.

Really strange. I tried different versions (2.71.5 and 2.71 in previous post) and now with 2.69. I am able to render and composite it just fine.

Go figure. I’m thinking of doing an uninstall/install. Here’s screenshot of my system user preferences. Just on a lark, I tried changing Compute Device to none. No effect.


Reinstallation shouldn’t make a difference but I’m not on Windows so wouldn’t know. I have never installed Blender either. You could try restarting Blender and file -> load factory settings and then try the file. It won’t save factory defaults permanently unless you save user preferences and/or startup file.

Tried it, no effect. (Dang, I’d forgotten how ugly the factory UI is LOL.)

Ok. I’m out of ideas. Could keep on digging if I were able to reproduce the error on my end but can’t. Node arrangement and alpha transparency were the only ones I would change if it were my setup but other than that, can’t find anything that could cause the issue.

I’m trying a full uninstall and then installing 2.71. We’ll see what that does. In any case JA, if you’re ever in Portland Oregon, give me a holler and I’ll buy you a microbrew.

Well, wasn’t completely out of ideas. Here’s a file that works on my end, maybe you could try that and see if it makes a difference. I opened new file in 2.71, loaded factory defaults, appended the scene from the file you provided, put the changes in I already showed and saved that.

holographic_shopping_console-p_ja12.blend (1.21 MB)

Thanks buddy, I downloaded it to my local drive. Here’s what I did in the interim. Did a full uninstall of both my Blenders, including app data. Downloaded and installed 2.71. Created a new test file with three render layers and three miscellaneous objects; works just fine, all layers rendered. Created a new file and appended the four objects in the problem file; works just fine, all layers rendered. Opened the problem file; only one layer rendered.

Best I can figure is, my old Blender installs were corrupting the files? Anyway, so far to good. Of course, tomorrow is another day…