Help Please - Screwy Weight painting problem

OK. This is probably something I’ve done, but I can’t see what. I’m fairly new to Blender.

I’m weight painting a simple arrangement of three hydraulic pistons, They are part of
a much larger model, and so far I’ve done exactly the same procedure at least two
other places on the same model.

But on my third attempt the weight painting is no longer working.

  1. As I go into ‘Weight Paint’ mode the mesh turns black when I expected blue.
    (see attached [2])
  2. But if I hit ‘f’, I get a blue color as expected [3]
  3. But then if I start to paint, the mesh appears to turn itself inside out!
    [see 4 - only a few vertices painted here]

Can anyone tell me where I’ve screwed up! I’ve checked the normals. they look
OK. I’ve also made sure to clear all other vertex groups (if any) from the mesh I’m
painting. Is there some clue to be had from that black color?

Thanks in advance. G.

Attachments


Grey32,

I just ddi a quick test, and duplicated your results by having normals pointing the wrong direction. Try going into edit mode, selecting all, then press ctrl n - recalculate normals outside.

Best of Luck!

Thanks OBI_Ron, but I tried it already. I also tried normals ‘inside’. to no effect.
Frustrating!

I’m going to take a careful look at the bones, It might be something I’ve
messed up there. G.

OK. Figured it out. Somehow I had managed to get a ‘negative’ scale factor on the
original cylinder of the three pistons. Because I then duplicated the original piston
to create the others, the problem propagated to all three.

Applying the scale and rotation to the object, then recalculating the normals fixed
the problem. But I still need to figure out how fix the scale without also applying
the rotation?

G.