[HELP!] Rig acting like camera?

Here’s a video of what happens: https://streamable.com/0u7ra7

The only addons I have used in the animation are (technically) B.L.E.N.D - Armature Rigging Modules and the Spring Bones addon, I have 0 idea of why this could be or is happening. It has never happened to me before and I can’t find answers online.

Whenever I press 0 instead of going on the camera it should, it goes under the rig. There are no other cameras present and whenever I delete everything but the camera it goes to the camera it should. Setting the camera as an active camera doesn’t work, it’ll just go under the rig again. I’ve also tried deleting the rig which will make it so it’ll go to the camera it should.

Heres some links to the addons that were used, and the blend file itself:

Spring Bones addon: https://github.com/artellblender/springbones

Armature Rigging Modules: https://jimkroovy.gumroad.com/l/ArmatureRiggingModules

Blend file: https://drive.google.com/file/d/19iHbzgkPVh9669QGbVj-TAXrVVwF5t4J/view?usp=sharing.

Edit: I appened the scene to another blend file and the camera worked

Sounds like you may have hit ctrl 0 whilst having an object selected, this will turn any object into a camera view!

You can just reselect the camera and hit ctrl 0 again to restore.

1 Like