Help! Rotation Snapping Problem.

I have no idea how or why this is happening, but anything I
rotate randomly started snapping in increments of 5.
I could not find anything about this on the forum.
It’s keeping me from finishing my project right now.

Also, (while I’m at it) I have also had the problem where
hold Ctrl while rotating not longer made anything snap
to the grid. It had no effect.

Is there a panel hidden in Blender somewhere that allows
these changes to be made? :confused:

Check User Preferences -> Views & Controls and the Snap to Grid options … Though it sounds to me more like some how you have your Ctrl button locked (like caps lock) somehow … ???

Maybe. It’s gone now. I think you nailed it.

I need a new keyboard anyway. It’s probably the cheapest piece
in the world. I think I remember the Ctrl key getting stuck a few
weeks ago while I was using some other software too.

Actually, now I’ve gone back to some of my blend files and the problem
still exists. New projects I’ve been working on do not have this problem
so this rules out me having any issues with the keyboard.

So, please, if anyone can help me. There has to be some secret menu
to adjust these settings. The hidden menu up on top of course has
the option to turn on snapping, but I don’t want it on all the time. I want
it to work like normal again where I just hold Ctrl while moving, rotating or
scaling things. It does nothing when Ctrl is pressed. Absolutely zero
snapping occurs.

I must have accidentally did some shortcut while bumping the wrong keys.

Otherwise this makes no sense.

If worse comes to worse I guess I could just append everything from that
blend into a new one. But this problem has happened least 3 times
within the last few months while I’m editing models. I’d rather have a
real solution than having to come up with a workaround process.

I also tried turning on all the snap option in the hidden pull down menu
and they did not even work. Snapping is completely gone. Where did
it go?

I’ve run into a similar problem with zoom. I think it’s some combination of control or shift key and mouse button click, but I haven’t nailed it down to the point where I can duplicate it and report it as a bug. Sometimes I can get out of it with a control+MMB click, sometimes I have to save, close Blender, reboot, and reopen everything. Since the rebooting helps, it may even be a problem with the mouse driver or the OS (Windows XP, here.)

Yeah. It’s a funny one.

My best solution is add everything you want to keep to a new group,
save it, Ctrl+X to start from scratch, then append that group in the
scene and save it.

That issues is something that gets saved into the blend file. So,
I bet that might help if someone wanted to look at it and see if they
can figure it out.

Oh my gosh I’m a freakin doof. I went back into that blend file to
get it ready to upload and I noticed that while holding Ctrl during
rotation, nothing happens…that is, until the cursor moved over a
different object in the scene. It’s been because that new snap tool
was on this whole time!!! Well, now I know how to use it.

Problem solved. :smiley: