Help sculpted rocks normal map on variation of cgcookie tutorial + Unreal4 question

Hello,

I’m making four rocks and trying to bake on to one image following a cgcookie tutorial
My first rock I was able to bake beautifully (and all rocks were present at the time - although I moved to their own layer to
Stop the others influencing the bake, even though I don’t totally know if this is necessary), my issue with the three others is parts of the map show up fine,
But they all have large sections that have green and orange parts instead of the nice purple and blues.

I’ll try and upload my .blend file, but maybe somebody would know off the top of their head what I’m doing wrong. I’m using cycles without cagess, but I tried making a cage and that didn’t help.

They’re occupying same spots, using smooth shading. What are common reasons for these colors we dont want showing up?

Could this be from setting the y axis different? Should all axises show as +x, +y, +z? I may have switched since I make things for unreal but pretty sure I’ve tried going back and forth to check.
I’ve also tried different settings for the ray distance on active to selected, as well as the equivalent setting for the cage.

I can bake details easy to a plane, but really trying to do manifold shapes has been a real challenge for me to completely get.

I just realized I can’t upload my blend file because my rock example is about 300 MB.
I’d love some advice for getting this down so I can get further into materials.

If someone wouldn’t mind helping with another topic with advice or pointing to a good learning resource,
But I’ve ignored learning making good materials in Blender
Because I always ended up needing to remake it in Unreal anyways. But if I make a nice material
using nodes and procedural textures I like, is it easy to take that work and bake
to a texture that would bring that material into unreal? Do I simply bake to a diffuse?

Here are some photos, I don’t get why I get an abnormal bake in this area for instance. The whole rest of the rock is fine,
And I’ve tried moving the verts around, changing ray distance, using a cage, nothing makes it go away.
Here are the pictures. Those two tiny ridges are mostly the only areas doing it and I don’t see what makes it different from the areas working fine.

Attachments



Oh shit, I got it. I didn’t realize some faces were flipped!! I’m so happy, it works!!! :):slight_smile: