Help seeing through front of mesh - backface culling and Geometry node not working

I’m modeling a catheter in a blood vessel and would like to set the material on the vessel to only show the backfacing faces. This way I can see the catheter inside the vessel no matter how I animate the camera around the vessel. I’ve done some research and the usual things aren’t working for me, which include turning on backfacing in the material editor, and setting up a mix shader with a geometry node plugged into Fac, principled BSDF node, and a transparent node. I still can’t see through the faces that are facing the camera. I’ve even tried my trusty 3DS Max trick of just flipping the normals on the vessel, but alas Blender doesn’t handle that the same way Max does. Any help would be greatly appreciated. Thanks.

In your .blend file, normals are pointing outside.
So, you have to flip normals or invert order in mix shader node (Transparent shader in first slot, Principled in second).
At that state, a Cycles render corresponds to black tube because of shadow.
So, you have to go into Object Properties tab, open Visibility panel -> Ray Visibility subpanel to disable Shadow option.

It looks like EEVE only supports one order of shader mixing with its transparency blend mode set to Opaque. Set it to Alpha Clip, and it should work in all cases.

1 Like

Thanks! I wouldn’t have thought to switch the order they’re plugged into the mix shader. This solution works great! Still not as slick as Max, but I’m thrilled it’s working well enough. :smiley: