help setting alpha

This is, no doubt, a newbie question: but after hours banging my head against this I have failed to figure out what I’ve done wrong.

I’ve set up a scene that outputs a selection of lightmaps, and I wanted to make a tree that would add an alpha channel and do some basic operations to each of them.

However, anytime I try to use blender to add an alpha channel it appears to execute some sort of operation on the r g and b channels as well as a - and I would have the rgb left alone/intact.

Any help would be appreciated,

thank you

Is this a render? If so, go to render settings and make sure it is a PNG, then select RGBA, set background to alpha, and it should render correctly.

The source files came from Maya, which doesn’t allow me to output pngs. The output that i posted was a snapshot of the viewer node to show what that tree did to the rgb channels (the alpha, itself, shows up correctly though.)

For the life of me, I don’t see a background option in the render settings: you aren’t by chance referring to the backdrop?

I don’t see a background option in the render settings

Blender Render = Render panel under Shading set Alpha to transparent
Cycles Render = Render panel under Film enable Transparent option

Rather than showing some arbitrary screenshot, post a link to your blend file (Pack ALL relevant textures in the File / External Data menu). It’s much easier for anyone who decides they may want to take time out of their busy lives to help you

My apologies, I packed my test scene here:

I must also thank everyone willing to help, I know it is especially taxing to shepherd those who have only recently started working with blender and are probably making elementary mistakes.