Help texturing the walls of a room

Hello, I’m trying to texture the wallpaper of a room (cube) using an image that simulates some bricks, I loaded the image as a texture, and chose XRepeat as 30 and YRepeat as 30, but the texture only appears properly at one side of the cube, what do I have to do so that the texture appears properly on all sides? I attached the texture image and the rendered image of the cube.

Attachments



Two Options:

  1. On the Map Input tab (in the Material settings) for this texture choose the Cube button.

2)The other option, is to Unwrap the mesh and then load the texture to UV coordinates instead of Orco.

I think messing with the x,y,z’s should do the trick. In the material window/map input.

It worked after changing the map input and rotating the cube. Thanks!