Help to activate CUDA on Blender under Mac OS X Yosemite using NVIDIA GeForce GT 750M

Aloha to all,

I’ve just got a new iMac with a NVIDIA GeForce GT 750M 2 weeks ago and I’m trying to activate GPU rendering for cycles, but in System/Compute Device don’t let me choose anything more than CPU. No idea why. It happens in both installed Blender versions 2.74 and 2.75.


Also, although not sure if is related, in Blender 2.75 all Add mesh extra objects menu for customize an object are not activated and unuseful (in 2.74 works).



What I’m doing wrong?

Concerning the greyed out primitive settings, try enabling “Global Undo” under User Preferences > Editing.

As for the CUDA thing - sorry, no idea. But I doubt that you will see much of a performance gain from a notebook-class graphics card anyway, especially if it is only equipped with 1 GB VRAM…

Have you installed the CUDA drivers?
http://www.nvidia.com/object/mac-driver-archive.html

After that you should see CUDA in system preferences.


When installed you need to enable it in Blender User Preferences at the System tab.


@ Noke, i just updated to CUDA driver 7.0.52 and it works just fine :slight_smile:
Regarding the future of Blender on Mac, i don’t see any problems.
But putting pressure on Apple to fix things needing to be fixed and asking for better things is always good.
It would be nice with an affordable external thunderbolt GPU box just for rendering purposes.

Thanks Jakerlund!