Help to up-date, "Add Corrective shape keys add on" for 2.8 or subsitute way? (solved)

Really apreciate if some one offer hint or teach me way (it is not matter, add on, script, which achive it)
but at same time, I hope it actually work as I asked. (because there are many case, it is supposed to work, but after try it, it not work,) I hope to get answer which actually solve problem for recent blender 2.8 version… (of course when there will be new-up-date for bpy I may try again,)

animation_add_corrective_shape_key_28.py (13.7 KB)

My problem is,

There is “posing mesh-A” morphed by armature modifier which use “preserve volume”.
mesh-A is morphed by some other modifiers (shirink wrap, rattice, etc etc) too.
but there is no modifier which change mesh-A vertex count (non-sub-d), and non transform as object local.

And mesh-A is deforemd by many shape-keys too. (some shape-keys are driven by bone transform, then each shape key set values , not pinned)

I think It is common status, when pose character with armature and morphed by shape keys. (for render still scene. though too many drivers, modifiers may not good to render animation)

Now There is “mesh-B” which have same vertex number of “mesh-A” and order in same scene.
and no transform. no modifier, then the mesh-B can be shape key (morph) of mesh-A without break mesh.
( mesh-B was generated from mesh-A by use “obj.to_mesh()” and I editted)

Is there way, generate new shape key (name = “clean shape”) for “mesh-A” from blender UI,
which change current “posing morphed mesh-A shape” to “mesh-B shape” identically, with keep all other setting? (modifiers, pose, shape-keys)?

Default blender 2.8 offer

1 “transfer shape keys”, 2 “join as shape”, 3 “generate new shape from mix” (sum of currently used shape-keys values)
But how mix use these 3 options, I can not generate new shape key correctly as delta from current shape. (visuall transformed shape)

I am beginner about python, but have tried it too. Because there was community offered add on, which can achive it for 2.7
then I up-date it and have used it for 2.8. But blender 2.8 is beta, then bpy have changed often. I keep up-dated but finally, At current I lost way for this up-date,

https://developer.blender.org/rB46eb5a0b8a4f3a7826b5e5a1a11e114e09037dba

if some one could help me to up-date plug in, (it worked a few days ago without problem for 2.8 ,I can confrim,)

I really apreciate, and hope you teach me what was wrong. The attached file is what I up-dated(I do not add sign etc, just have up-dated for blender 2.8 and have used it)

=========
thanks I could get answer from blender BF report.
https://developer.blender.org/T63244

now it work without problem.