Help understanding flat/smooth sub-surf topography issue with simple model

I’m fairly new to Blender and trying to stay simple but have good form with some beginner modeling.
I am fussing unnecessarily over a lot of things just to see how they work and chose a simple (but not) project to model, the iPhone X. If you’re an Apple hater that’s ok I didn’t choose this because of the brand or whatever but because there are so many good reference photos to work with since Apple takes so many hero pics and videos.
Anyhow I can’t really figure out Subsurf, and I know I will need to before I can ever seriously model anything. I’ve attached two images. See how in the rendered view there’s “stretching” (is that what you call it) on what I hoped would be a flat glass surface?
I read lots of stuff to try to solve this on my own, and tried everything in the EDGE, VERTEX and FACE menu options under MESH, but nothing seems to be making this better. Everything seems to make it worse.
(See the little “fins” poking up from the reflection of the plane?)
TL;DR: How do I make the stretched edges in the render go away when the desired result is a flat surface?



Hard to tell as you have set sub to visible on the edit mode, but i think you have just do an extrude and then have an ngon in the center of the face.

Your mesh should look more to something like that. try keeps quads with subd modifiers and keep equal meshes.



But well the glass is separated from the bezel, so can just create the face separately.

subsurface.blend (472 KB)

( Note, i have just start with a plane, keep only one corner, bevel it, inset for create the bezel, then i have use the knife tool for connect the loop from the bevel. )