Help updating from Blender 2.69 to 2.71 on Kubuntu

I installed Blender using the Muon Software Center on Kubuntu. I run the app and it was Blender 2.69. So I downloaded Blender 2.71
for Linux.

I extracted it then I try to open the blender.exe. Blender won’t run and the “open with” dialogue box appears. Did I miss something? Why won’t it run?

I think I should replace Blender 2.69 files with the 2.71 but I don’t know where is the blender directory located.

open a terminal, go to that downloaded blender directory ( cd Downloads/Compressed/blender-2.71-usw). Then you type ./blender and tell us what happens.

Nah. bash: ./blender: Permission denied

That’s weird. You download Blender in your “/home/YOUR_USER” and you try to run the “blender” executable from there. Do not download Blender into another disk or partition, only in your home.

Just in case, you do not use “sudo” for any of this tasks (download Blender/uncompress tar.bz2)

Alright it worked. I also downloaded dependency packages.