Help w/ Setting up CUDA for Windows

I just really started using Cycles and was surprised at how long it was taking to render. The solution to speed up render times, based on an internet search, was obviously to render off of the GPU rather than the CPU. However, when I tried to switch Blender’s settings, it did not offer the option of using the GPU:

Somebody at the Blender IRC channel (JA12) said to use CUDA. Now, I have zero clue what this is (heck, I hardly understand what a GPU is), but I searched and downloaded the 1 GB installation from here. My PC does indeed have an NVIDIA card. It is a “2GB Nvidia GeForce GT630”. (Here is my computer.)

So I downloaded and tried to set up the CUDA thing. It was so foreign to me that I was just mindlessly choosing all of the default installation choices, because I have absolutely zero clue what any of that CUDA stuff means, I’m sorry to say.

So after apparently completing the CUDA installation…Blender still does not have any GPU options in the User Preference, and CPU is still the only choice.

I suspect that the problem is something in the installation of CUDA.

I have Windows 7, 64-bit. As I said before, I am a total newbie to both graphics cards and CUDA. Is there anybody who can assist me with diagnosing why Blender won’t let me render off the GPU and, most likely, how to properly set up CUDA?

Thanks as always. (Great thanks, in this case, since this is a pain in the butt.)

Do you have the driver for your gfx card installed? You don’t install CUDA separately, that’s for developers (Suggest uninstalling it). However for a non custom build computer to not have drivers pre installed would be unusual, however seeing as you are using XP i suspect you had windows reinstalled because that’s pretty old and you wont get it in any store. Also note that there are some things in Cycles that don’t support GPU compute although usually what will happen is you will still see the gpu option but the shader wont work until you switch to CPU.

Are you using an official build of Blender… like from the blender org website David? I know many of those builds at graphicall often don’t include cycles in the build…

I would say uninstall whatever Blender version your using and go download an official version as a first step. What I don’t know is what kind of problems were created tryinjg to install cuda… Like Jeremy said, you don’t do that… if your card is a cuda card and you have the drivers installed… all you should have to do is open the preferences like you showed and your card should be recognized and give you the GPU option.

Hope you can get it worked out.

Okay, I went to the NVIDIA website and am downloading the driver for my card (I think). If this works, then I will delete CUDA. (Also, I have Windows 7; I just set up the interface to look like XP is all.) Thanks for the advice, and please watch the thread in case this does not work.

I am indeed just using the main Blender build. This is nothing from GraphicAll or anything. So the problem was not necessarily anything related to Blender.

Well, this isn’t good!

It appears that I don’t have the NVIDIA graphics card, after all.

When I tried to install that Driver, it gave me a notice that it couldn’t find the associated hardware. So, I then went to my Control Panel and under Device Manager > Display Adapters, it said I have “Intel HD Graphics 4000”. This is disappointing and odd because the HP product page for my model clearly says this has the NVIDIA card.

But does this Intel card rather than the NVIDIA card mean that Blender can’t use the GPU for Cycles?

You might have a Nvidia card too.
The HD4000 is an integrated graphic chips inside Ci5 and Ci7 IvyBridge CPUs. It’s a so called IGP, not a graphic card per se.
The display connector should be on your mainboard (usually DVI, VGA and HDMI) between the USB and Network ports.

However, there should be another, at least DVI connector down where your expansion card slots are on the back of your PC.
Windows does not recognize or install graphic drivers for display adapters without a connected display. That might be why you could have a dedicated Nvidia card, but it’s not showing up.

Cycles needs CUDA to work “properly” in GPU mode.
Only Nvidia offers CUDA compatibility.

Okay, this pretty much explains things. I do not have the NVIDIA card, for certain, because I just spent a long time with HP’s tech support to verify it. (The driver for the NVIDIA card, as well as the installation CD-Rom were included in my computer, but the card itself was not. They did that because some different versions of this computer come with them.)

But because the card I do have is integrated, it is still possible to purchase a new NVIDIA graphics card and install that? If this is the case, does anybody have any suggestion for the cheapest NVIDIA card compatible? Because Cycles is just prohibitively slow when rendering out a full animation. Even my current simple scene is a full 15-minutes for a relatively noise-free render per frame!

David, you have a fast system with i7 CPU and you need at least a GTX 660Ti to beat your CPU.
Compatible are all cards with Cuda Capability > 2.0.
So you could start wit GT 610 but ugly slow.

Cheers, mib.

Thanks a lot for the link, mib3berlin.

Man, these things are not cheap at all. I’ll hopefully be able to purchase one some day, before too long. Thanks again.

Personally I’d recommend to get a used GTX 480, 560TI or 580 or try to get a used 660TI which could be hard, as they are quite new.
A used GTX580 is available for 120-150 Euro, 480 and 560TI cheaper.

If you wait until mid may, chances are good for a new batch of used cards flooding the market, as the GeForce 700 series is supposedly released and many will upgrade.

Okay. It’s doubtful that I’ll be able to afford any before May, and so that timetable should work out well for me. Thanks for the tip (and I might end up chasing you down for more advice when it comes time to actually buy one.)