Help! Weird mesh

So, i have an object from archimesh, it’s table cabinet (floor). the top board is weird. Using bevel modifier on it, would produce some weird glitches. Checked with merge by distance, 2 vertices removed, but the glitch still here.

further checking, the weirdness keep going on. i tried to delete the top box then i started by using loop cut to make the topbox again. When i try to precision 2 cm, by typing 2cm, but the edge length shows its not 2cm.

What is this? how do i fix it? i already tried Ctrl A + apply scale too. no avail.

i tried to make it my own, bevel modifier works fine. But I already using that (the glitch one) 8 tables. Gosh, i should remake it and duplicate and precise them again?

Sorry for my bad english!

I know this doesn’t help much but doing this accurately is an issue in Blender, but you can look here for a possible fix.

1 Like

ohhh didnt saw that one. But i ended up remaking them…I remaking that with same centimeters as original bugged one, and it played correctly. Archimesh objects are sure weird.

But anyways, thanks for reply! :))