Help: Why aren't shadows appearing?

I’m still fairly new to Blender’s game engine, but I can’t get it to show shadows. I heard that only spotlights show shadows only, so I made a spot and pressed P to start the game area and didn’t see any shading, all objects were bright. Is it my pc or my settings that is causing the problem?

Thank you.

You probably forgot to change the rendering to GLSL. So after you make sure you are in “Blender Game” rendering, you go to the “Render” panel in the “Properties” window (or press N in the 3D view port) then select GLSL from the “Shading” area. Be also sure to have texture mode on by pressing ALT + Z in the view port. The sun can also cast shadows.

Thank you for the reply.

I do have it on GLSL mode, nothing changed from there and have texture view turned on and it’s not casting shadows still as everything is shadeless for some reason. My materials are set to cast and receive shadows.

Try with this very simple scene.

I’ve begun with the default scene you get when you open Blender. I’ve just added a plane and scaled it up a bit, changed the default point lamp to sun and changed the settings that are red colored on the picture. Nothing else. That should work for you.

If it doesn’t work, maybe you don’t have GLSL on your computer ? (possible on cheap/old devices likethis one for instance that doesn’t have a GPU)

EDIT : I’ve just noticed that when you turn the default point lamp into a a sun lamp, shadows are enabled by default in the sun lamp panel, but they are disabled by default if you turn it into a spot lamp. Tricky… Just tick the according box in the spot lamp panel (the one which is ticked on the right of my picture in the sun lamp panel; I hope i’m clear ! ,-) )

It didn’t work. No shadows were cast, but the box was shaded with the sun lamp. I guess it’s because I have an old laptop then. It’s not important, but it’s a Dell Latitude D820 with Windows XP.

Blender was supposed to stop supporting XP compatible versions so maybe try an older version of Blender (2.66 for instance, BGE hasn’t changed that much) but I wouldn’t bet too much on that. It’s probably a hardware problem as you suggest.

For the record, I discovered the other day that shadows don’t appear on materials that have 0 specular intensity. You have to have at LEAST 0.001 in the “specular intensity” field for it to work. Hope that helps, at least a bit.

Maybe you could test with this file. Change Lamp Type to Sun to see it works on sun lamps too. If you don’t have shadows, except when you change the Material Specular Intensity to something higher than 0, than it probably is related to graphics cards.


Buffer_Shadows_no_bug.blend (82.3 KB)

I don’t have this problem here (Blender 2.71, Windows 8.1, GTX 780).

Wait… You mean that’s not supposed to happen?
It’s probably got something to do with my version of Blender. I’m running 2.66 because I don’t like the lack of a touch sensor in later versions.

That could be it. Did you try with the attached blend?