Help with Background Transparency

So here’s the render


and I wanted to render it with the background transparent so I checked the Transparent box in Film and then got this result:

I got some grass in front and I cant see the blue light above…
Why is this happening?
Im using the latest Blender version 2.90 btw

Hi,
The rest of the blue light may actually be there, but too light to see with white background. Take the render into image editor and put on top of black background - does the blue light reappear?

Sorry forgot to mention. Nothing appears when I do it in Photoshop:

1 Like

I would try using the Light Path Node in your world settings…Like this and it will stop the HDRI from Rendering but give you the light in your scene. If you are using an hdr image for the background…if that is just a Background image it will still work…exchange the HDR with the background image.

2 Likes

This’ll work, thanks!

1 Like