Help with camera tracking !! (blend file plus video included)

Okay, so I got the tracking part right. Have added a cube in the scene successfully. The problem is when I render, the background(original) video doesn’t display. Help me with that.

here’s the file with video in same archive:

http://pmc.do.am/wwrr/track.zip

screenshot:


guys help me!

Hey!

Use a compositor to add background to your animation… If you still find yourself stuck come back.

Take care!

how to use compositor? where is the compositor? I’m new to blender !! plz help !!!

http://www.sendspace.com/file/kekbs2

Here u go…

Thanks ALOT!!!

I hope you dont mind one more little thing, I’ve been searching alot on the internet, but couldn’t find the solution for cycles renderer…

The problem is I need a shadow for the cube, but don’t want the plane to be visible…An invisible plane on which shadows can be cast by other objects but the plane does not reflect any light. I hope you understand what I’m talking about, its very commonly used on other 3d/compositing softwares…I’ve done it on 3ds max, but can’t figure out on blender…

thanks!

one more problem, where did you get the “render layer” box from in the node editer?

I am using the original file (which I uploaded) and in the node editor, I remove everything and add new everything just like your setup. But when I press shift+a and add input “render layer” , the option says “foreground” or “background” where as it should be “render layer”. How do I fix this…sorry if this is stupid question, I could really use some good tutorials…

okay bump.

someone plz help?

some one has GOT to help me with this!

No problem!

Google is your best friend…

Take care!

You know there is a sub board for compositing right? You will get more replies there I would expect.
http://blenderartists.org/forum/forumdisplay.php?31-Compositing-and-Post-Processing