Help with creating a chamfer on a edge

(Augusto Antipou) #1

Hello guys, first post here

I’m new into 3D Modeling and wanted to start with an object so I could learn the basics and most of the features in a fast and simple way, so I saw this “Ultimate Grenade Tutorial” on YouTube and gave it a try. I find it a great tutorial, really complete and on a moderate pace, the guy is using 3Ds Max, but that is not a big problem, until he makes a chamfer on a edge, I just couldn’t find a feature like that, or make a workaround, I already tried everything I could, new meshes, modifiers, all the toolbox items and I just couldn’t replicate that.

My issue is from 5:38 to 6:20. See the chamfer on the edge he makes at 6:10? That’s what I want to replicate.



This is a video I found that is exactly what I need, but unfortunately doesn’t work on the shape that I have.



And this is the manual page:

See… I have all the resources, I know what I want to do, I know how to do it (kinda/not really), but using the method on the Blender video or the manual won’t work with my shape. I know there is a Blender tutorial on a grenade (I saw it, it taught me how to use Blender), but I didn’t quite like the way the guy does the body and I couldn’t follow up with the upper part (the handle and the fuse). Please help!

P.S.: Classic noob statement: I hope this in the right section!


I’m trying to do a Mk2 Grenade like the one on the above “Ultimate Grenade Tutorial”, my main use for it would be just to have the model to admire it (I guess that’s static image), and maybe later try to put it in a game (but that’s not the objective for now).

What I wanted to do was create a chamfer on the edge of the first (top to bottom) “pine” (which is different from the others since it is connected to the faces directly on top of it), unfortunately I didn’t find a option similar to that and using the Mesh>Edge>Bevel didn’t work as expected (or I don’t know how to use it at all), it just creates bevels from the vertices instead of the edges.

Attached is my current .blend file, right where I am stuck at (and hopefully with my reference image, but if not, here it is:


mk2grenade_edgechamferproblem.blend (285 KB)

(JA12) #2

“It doesn’t work” is not enough information to work with. You’ve posted all of that and not a single bit of information what you’re working with and actually have.

Bevel works in that situation. If you want to know why it doesn’t work for you, post an example .blend and maybe someone can help figure it out.

Since it’s your first post, that’s alright, but posting a support question is not rocket surgery. You need to

  • tell what you’re doing, what went wrong, what you expected
  • use images to help you explain
  • include an example .blend that demonstrates the problem
  • not read the above 3 and leave the .blend out and crop the screenshots like so many others. Having those three means including the most amount of information with the least amount of writing.

How and why

What is not in there is that the end use of the model is quite important to mention. Whatever is being done to or with the model can change a lot depending on if it’s for still images, animation, 3d printing, game engine use, other (what?).

(Martynas Žiemys) #3

Object mode -> ctrl+a -> apply scale

(Augusto Antipou) #4

Mr. JA12, I edited the original post with more information, hopefully that helps, feel free to keep correcting me and ask for any other info.

Object mode -> ctrl+a -> apply scale

Not sure what that’s supposed to do since it doesn’t give me any visual feedback and doesn’t seem to change anything in the mechanics.

(JA12) #5

Unapplied and non-uniform object scale. Ctrl+A -> scale to apply

And if you follow the tutorial, bevel works just fine. You said it bevels vertices, which it doesn’t unless you enable vertex option from the operator panel, or use the wrong hotkey ctrl+shift+B (vertex bevel) instead of bevel (ctrl+B).

(Augusto Antipou) #6

Thanks for the reply!

It worked now for some reason, and I also know why one of my (many) tries at this didn’t work.

I didn’t quite understand this “line” that follows my cursor at first:

When I clicked this happened:

(See that triangle it forms on the side?)

What I wanted was this:

(No triangle. It just binds to the existing vertices)

What I had to do was increase the bevel (ammount).

I feel dumb now :stuck_out_tongue:

Thanks for the reply guys, my problem is now solved, I just still don’t understand what (Object Mode) Ctrl + A > Scale does/is supposed to do. Again thanks for the help!

(Martynas Žiemys) #7

I think it’s a common problem for beginners. If an object is scaled in object mode in one axis more than in others, when you do a bevel operation you will see result as if it was done on the original mesh and only then scaled so the bevel looks unproportionate.

(JA12) #8

It transfers the object scale multipliers to object data, and then resets the object scale back to (x,y,z) 1,1,1.

Objects are manipulated in object mode, and they may consist of object data, which is manipulated in edit mode. Modeling tools and modifiers work in object data level, object data being the mesh in this case.

When the object scale is anything other than 1,1,1, it means you’re looking at an object and its data with different dimensions than what tools and modifiers see, and they don’t seem to work as they should. Applying the scale makes the mesh dimensions match the object.

So if you followed, changing the size of an object doesn’t change its object data. If you scale an object, its scale values change. If you change its dimensions, its scale values change. If you scale an object through its parent or a constraint, its scale values don’t change because it follows its parent, but it still means it doesn’t change its object data, just the size of the object.

That’s bad when you’re working on things that depend on seeing the object data in right size, which includes modeling, UV unwrapping, and sometimes the mistakes from those may reach texturing, lighting and rendering.

(Augusto Antipou) #9

Thanks for the explanation guys!

I just noted, uppon closer inspection, that I may not be getting an actual bevel, if you compare my images with yours, it’s just different. Mine keeps doing a bevel with another vertex, while in your image it just does it between two vertices, not three. (This is getting hard to explain, please forgive me if it sounds confusing.)




(JA12) #10

Yes, you’re beveling the edge between quadrilateral faces (4 sides). You don’t do that for the whole loop so it creates a triangle (3 sides) to support the new edges.

In the tutorial he adds new edges, moves the edges a bit, and then creates the chamfer, so I did that too. The edge loop that gets beveled is the whole loop, which stops on both ends which have an n-gon face (more than 4 sides). As it’s an n-gon, it doesn’t need a new face to support the new edges for bevel.

Before beveling the edge loops end on an n-gon, or could call that a 5-gon or a pentagon if you like because it has 5 sides. After beveling it’s still an n-gon with 6 sides, so 6-gon, or hexagon.

The number of sides doesn’t usually matter after a face has more than 4, so all of those faces are usually refered to as n-gons. Blender does show the number and can select based on number of sides on a face, but the information value usually is with more than 4 and if it’s an even or an odd number.

(Augusto Antipou) #11

Ok, so I guess my problem is with the edge, more precisely creating the new edge(s), how can I do that?

If I use the “loop cut and slide” in Mesh Tools, I get it all around the object, like this:

If I apply it to the upper part it kind of works, but I get problems later, like this one:

(See how it creates a strange face in one of the sides?)

Again, I may be jumping some steps and not noticing, but I swear I am trying my best at this.

(Also, the late replies are because of the new member restriction.)

(JA12) #12

I could answer that question but I’ll say something else that I think is more helpful instead.

It seems you’re not at all familiar with Blender tools, which is ok, but following a 3DS max tutorial to learn them is not. Blender is very different and you’re not really learning Blender when watching a 3DS max tutorial to do things, you’re learning to use Blender like it was 3DS max.

You could do that to extent, but what you’re missing on is that while the structures we model can be similar or the same, the tools and therefore the workflows to get there are different. What is even more important is to not learn steps from any tutorial but the methodology, in which the tools are Blender specific, polygonal modeling basics, and topology theory are universal.

The goal of watching tutorials is to build your knowledge base enough so you can start modeling your own, which requires to understand enough structures and know enough about the tools so you can decide on workflows before you start modeling. There are a lot of tools and everyone models differently, even though the end result is very similar. There are many ways to do most things, and the “best way” people ask about is you to know the options and decide on the best workflow for you, whatever you’re doing, not just what tutorials show you.

You’re not going to get that information from that tutorial. In general it’s ok to watch tutorials which are done with other modeling softwares, but you’re not supposed to follow their workflow. You can watch and try to learn things that are universal, like the mentioned above, and things about the pipeline and requirements that come from the end use. Basically the reasons why the model(s) are built with the structure they end up with.

You could watch that tutorial without following too, but don’t take his words as the final truth, watch many tutorials from multiple sources. In that he says “I’ll remove these edges to reduce poly count” which is almost completely crap. Yes, he has less faces as a result but removing those don’t provide much/any workflow advantage, and the triangle count in the end stays the same so he’s not reducing poly count to make any difference in performance in low poly, and in high poly his changes don’t matter.

Beginners somehow get the idea that removing unnecessary edges is good and end up with a mess, because they do that without knowing which edges are unnecessary so all edges look equally removable. A tutorial removing edges because it removes poly count is bad advice, should either tell the real reason the edges get removed or not give a reason at all.

Pipeline I mentioned

And would recommend watching these

And then continue with Blender modeling tutorials that make a simple model.,, Blender cloud have tutorials if you don’t want to search for random ones.

Post on the support forum if you get stuck, and here’s how to do that

(Augusto Antipou) #13

Alright! Thanks for pointing me in the right direction! Thought modeling an object a little bit more complex would step up my learning, but apparently I still have to be a little more basic. Thanks for the handy links!

(colkai) #14

If you do a gogoel search, on “blender grenade”, it would take you to this by Blender Guru

See how you get on with that. :slight_smile: