Help with cycles and light noise

Hello, I’m trying to figure how to render a quite simple scene without huge noise I’m getting. I’ve tried to play with the light settings and render settings and so on but yet the render is taking huge times and really bad results (a lot of fireflies or noise). I can’t seem to get this working. I need to use the lamps instead of difuse shader (it’s for a college project) and that might be the reason of all that noise. I’d be very greatful if someone manage to help me. This is the link for the file:

thank you!!

Hi RuivoM,

Your Sampling Settings are too low. Try to increase Render AA Samples to, say, thousand or a few thousands.

Unable to open project right now (image would help) due to being at work. But you mention lamps. The more the amount and smaller their size, the more noise you’ll get. Try rendering them out in isolation and adding them together in post. Post may also be a way of fixing isolated fireflies.

Not seen as a blend file - scratch that, iffy download, tried again. Turn on multiple importance in the world settings and set the value to at least 1024.
You want at least 250+ samples for your diffuse. Is it meant to be nightime? If so, you might want to think about what your lighting is, such as make your round lamps an emission.

Have just checked. .blend file is present.

Thank you for the replies! Yes it’s a night time, someone above mentioned more samples however I tried something like 200 samples and takes A LOT and I need to make key frames for this so if I get a frame that will need like 30 min each to render it will be impossible for me to get it done. I need those small lamps on the street lights but I can’t avoid that noise. I’ve already made the ‘park lamps’ emission so it gets easier but still those light street lamps are full of noise. :frowning:

Having your lights within a glass enclosure usually is not a good idea: You’re basically lighting your scene with caustics, which is destined to cause noise…

Try making your lamp “shades” invisible to shadow rays (Either on the material level by using a Light Path > Is Shadow Ray driving a Mix shader to transparent or in the Object > Cycles settings. In both cases you will have to tone down the light strength.) and perhaps also disable reflective and refractive caustics afterwards.

Thank you again for the replies. I’ve been editing and working a bit and it’s getting better. I swapped those park lights for emission shaders and it’s looking good, however those lamps (billboard and road) have a lot of noise which I can’t get rid of. I’m attaching my render settings and a screenshot so it could help.

Does anyone know how to get rid of this:

I need to be using Spotlights but, I’ve 10 set in clamping direct and indirect and doesn’t seem to make any difference using it or not.

First, before you even start using Cycles it’s good to know what exactly happens when you render: Camera (!) shoots out some ray tentacles to check where it has to reach and where not. It happens not knowing anything about the scene, randomly. If ray hits something it reflects according to optical laws, some information is stored about what got hit Diffuse, Glossy or Light source. Next reflected path is analysed similarly and so on - times you set in sampling.
Now, since lamps are not visible directly in your image Cycles has a hard time getting some random ray out of the Camera hit the asphalt (Diffuse, reflection ray will start in a widely random directions) reflect and hit the lamp. Cycles is severely ‘dumb’ in finding small light bulbs just by reflected rays. Also ‘random’ is a quite limited amount compared to what mother nature can afford (trillions of rays hitting each surface). ‘Random’ might repeat itself in calculations - as a result you get these fireflies - rays more than often travel same directions and bring back lighting information in one pixel range where this value accumulates.
Such information brightens your monitor up to the limits - file where information is stored can keep much higher values however.
Here Clamp starts to play - if you set it less than 1 (=value your monitor is able to display) you get overall darkened image, if you set clamp to 10 this will limit maximum values of light to 10. Setting Clamp to 0 does switch off this mechanism.
Clamp is not a universal cure to fireflies - idea behind is if you want to use image containing bright pixels in compositing, such values ‘damage’ image mixing calculations, bring in further distortions.

This all was to “I’ve 10 set in clamping direct and indirect and doesn’t seem to make any difference”. Details -> RTFM.

Have you read anything about how human eye perceives light, what are differences between “dark” and “bright”, what does colors look like in the midday and during the full Moon? Check out and try making midday into the midnight using Blender’s compositing or any other image editor.

1 Like

Didn’t notice that Blender process was similiar to our eyes as for the lights. I know about the ray traces thing and how about the camera sees it, however I don’t see any explanation why can’t I use small bulbs for this operation. What’s the solution here anyway?

Here’s a much less noisy solution. I basically replaced all the Lamp-type light sources with Mesh Emitters, and set all shaders with Emission nodes to Multiple Importance = disabled (unchecked) except for that used on the mock spotlights (Luz2). I tried to get a late twilight look, not quite full dark, in keeping with your background image. Hope this gives you some ideas.

Darn! The revised file is too big to attach, even compressed or zipped up. If you can PM me with an email address I can send it to you as an attachment. I don’t feel like signing up for Dropbox or the like just for one file transfer.

Blender does what you tell it to. It operates on images in so called linear space which is pretty far from what you can physically display on a monitor and is off by mile compared to how your eyes see things. This however allows to do proper intermediate math needed and at the end image is brought back to account for technical and vision limitations.

Making things darker in a render does not quite bring you image which would nicely represent evening hours. It just brings pita to the waiting game and grainy image.
As to the evening colors - grass ain’t so green in a dusk, red - not even close.

“why can’t I use small bulbs” - “since lamps are not visible directly in your image Cycles has a hard time getting some random ray out of the Camera, hit the asphalt, reflect and hit the lamp [to tell it’s even there]”

Has anyone done a reasonably close to real purkinje effect? Either as a colorspace/adjustment thing or as a postfx thing. Blue for night would be okay’ish in a live environment, but why settle for that when we have the power of today?

The problem originally posted is excessive noise due to lighting choices. Whether or not the colors are accurately rendered for twilight is at best a secondary consideration, one the OP will need to solve once the lighting is squared away. In any case the scene is pretty obviously not intended for a photo-realistic or even naturalistic rendition, so color choices may be dominated by personal aesthetic choices rather than trying to match physical reality. Artists do that sometimes.

Sent you a PM.

As for the scene and grass, my scene is now a bit different but as you can see I couldn’t solve the lamps problem yet.

I’ll give a look when you send me the file! :slight_smile: THank you.

I gotta say you are asking a LOT from Blender and Cycles, with all those light sources! Since they are all static you might consider looking into ways of baking the lighting into the shaders, and use actual lights only where needed for interactive situations.

I’m depressed and tired writing all this :D.
Has anybody looked at the scene’s object scale and size yet? At the objects themselves (fountain as a first suspect)?

Me too, i could not get rid of the graininess, 600 samples was not yet there. Candidate for the denoising build?
Render settings

@CarlG Probably not, due to what they write:
“Kruithof’s findings may also vary as a function of culture or geographic location. Desirable sources are based on an individual’s previous experiences of perceiving color, and as different regions of the world may have their own lighting standards, each culture would likely have its own acceptable light sources”

My gosh, all the arm-twisting going on. Or not. :wink:

While Easter Egg thread is a dreadful amount of read now when it’s 800 pages and still incoming there should be a plenty of citations of “Cycles lights should be used (render done) on a real scale (Applied) objects sized based on assumption 1BU=1m” all over the Forum.
Btw, is this to be found on RTM pages? I don’t find this easily. Could be i’m just daydreaming and this is not the 42?
I just could not imagine this scene is a microscopic not applied scale which causes most of the problems.
Besides, i did put ‘Kappa’ after the ‘arm-twist’ :wink:

Btw, file size is huge because of one converted particle system’s mesh and one still being generated on that lawn…