I am making a mineride, which involves a railroad track and posts.

I am following a tutorial, that up until now has worked.

I went from this:

To this:

using Dupliframes.

It worked, straight away.

Then the next step was to do the exact same thing, but use a shape like this:

And make this:

But for some odd reason it is not working.

I have tried different methods all day, and everytime I get the same problem:

The post follow the track like I told it too, but then when I click “DupliFrames” it doesn’t create virtual copies like it is supposed to. :expressionless:

It just remains the same.

I experimented by adding a plain sphere to see if it duplicated but it had the same problem - it just sits there without making virtual copies.

I don’t know what I am doing wrong.

I did it right once, then when I tried to do it again, using a different shape, it didn’t work. :<

Does anyone know what I am doing wrong?

Thanks in advance! 8)

just move the original ( the real one ) into position, and the rest will follow.

I already did that.

I put the posty looking thing at the beginning of the track, held shift and then parented it with the track (Follow path).

I press Alt-A and it moves along the track.

I press Dupliframes and nothing happens.

Thanks for helping anyways. :smiley:

i don’t think you want follow path. try normal parent and see if that works…

Tried it.

Didn’t work.

Dupliframe, is supposed to replicate a frame, numerous times.

If the post is standing still then it can’t replicate anything.

It is a follow path. I did that with the track pieces and it worked then.

It just wont work now.

Can only one object be duplicated per track or something?

Because it wont work with any other simple objects either.

This is frustrating.

Thankyou for your help again Modron.

Any other ideas . . . anyone?

ok just do this: duplicate your track, use alt C to convert it from curve to mesh, delete the vertices you don’t need, then instead of dupliframes, just use dupliverts instead.

Just to clear up what Modron said.

Parent the frame object to the curve using Normal Parent option
Select curve and in edit buttons turn CurvePath on
Select frame and in Object (F7) turn on Dupliframes
Set DupOff for number of DupliFrames to draw.
Yes you can have more than 1 object parented and dupliframed to the same curve.


What are your settings for DupStart, DupEnd, DupOn and DupOff (for the cave support beams/braces) ?

First of all thank you everyone for helping me out.

I tried everyones ideas, and its not working . . . still.


I would like to put my project on the internet, so that perhaps someone could take a look at it?

Does anyone know where I can upload, .blend or .zip files?

Thanks again, everyone.

Never mind.

I found some webspace that will let me do it.

Click this link or copy it into your browser:

It is where I am up to, so far.

If there is a blender genius that would like to take a look at it, and try to figure out what I am doing wrong, that would be great.


Anyone figured it out yet? :-?

Can’t seem to get at your file! Try hosting it somewere else?


same deal here. standard 404 error



Well I spent 3 hrs this morning looking for webhosting that will let me upload .zip or .blend files.

This was the only decent one that I could find.


Does anyone know of any FREE webhosting that will let me upload .zip or .blend files?

I use Freewebs :

Could be worth a try :smiley:


Thanks kevin.

It worked.

Here is the link:

Thanks in advance to anyone who figures it out. :smiley:

Select the frame (Cube.003)
Shft-select the curve (rails)
Ctrl-P -> normal parent


Did you try it?

Because I tried it.

And it didn’t work :frowning:

When you clicked Dupliframes, where numerous amounts of posts (Cube.003) placed all over the track?

I think it has to be follow parent because otherwise it wont move which means you can’t you can’t dupliframe it.

However, if it did work for you, could you please, explain in easy instructions, please?

If you could that would be great.

Thanks :smiley:

How do you think I know the datablock names of your objects if I hadn’t tried it?

Go back one page and read all the instructions again:

Use “Normal Parent”!


OK, I opened your blend, and the posts were selected, I held Shift and Pressed selected the rail then I pressed P for normal parent, as dupliframes was already selected I got multiples of the posts as expected, I then changed the Duplioffs and got less of the posts…seems to work OK :-? :slight_smile: So don’t know whats going on :o