Help with .elu export

Hi guys,
I need someone to fix a problem for me. It is about the export.
I used Cinema 4D to model. Exported it with this extension: (.obj)
Imported it in blender. Textured it by using UV mapping. Tried to export it to .elu
Its for a game, and I used a custom script for it. But when I tried, I got this error:
‘NoneType’ object has no attribute ‘getTextures’.
So it doesnt seem to work for me:(.
Does anybody know how to improve the code or to find a solution??
Thanks in advance

(i dont know, but url is not possible???) and code is too long?? (really annoying xD)

my sword: (just in case you want to see it)

(you will get money if it is script improvement via pay pal

Does not the existing elu exporter work ?
You’ll have to use blender 2.49 but if blender is just to apply a texture then it shouldn’t matter which version you use?

the one i showed in that pastebin link??
no not with cinema 4D combination, as I said so it I got that nontype gettextures error.
Oh maybe I need an older version of blender?? could that be the problem?? I will try it:)

Oh I am a silly:S I have already blender 2.49b so no thats not the solution

I’ve not opened your link but is it the same as this one ?
Tried with a simple uv textured cube and don’t get any errors

yes, thats the one: :wink:

this could help u

www . forum . ragezone . com / f311 / blender-elu-exporter-error-578948 / #post5052243

this guy had quiet the same problem as me:(

oh wow listen,

the problem is… I used Cinema 4D… :wink:

Post your blend or obj file

sure 1 sec, ill give you everything…:slight_smile: its really cool!:smiley: (especially because its my first model project ever:) )

www . multiupload . com / LVTF1C4090 this is the .c4d
www . multiupload . com / 128WRX44H2 this is the .obj
www . multiupload . com / Z1FVB0BK2O this is the .blend and is already textured, this one does not allow me to export it to .elu

You hadn’t given your sword a material and added the texture to the sword. Try exporting from this blend file
Just using the uv image editor doesn’t apply a material or texture to an object.
You also have hundreds of double vertices. In edit mode select all vertices (A) and use W / Remove doubles

hey thanks it worked, could you explain those 2 steps, how you did that? thanks alot man you are a great help!

About materials
About textures
Applying the image as a texture to your sword