help with emitters please

I am having a wrong effect while trying to use emitters as lights. See pic how the light scatters in pixels instead of as a light would do “filling an area” What am I not doing right?

2nd see the ring that ring rotates as it slides up into the top position. I want lights in the ring at 12,3,6 and 9 positions. Great if they would pulse too… How to please?

Thanks for any screen grabs and details appreciated!
Regards
NC


Give the object two materials, the base material not emitting and the second material as an emitting material. Select the appropriate faces and apply this second material to them. The option to apply the material you’ll see when you are in edit mode. Keyframe animate the emitter strength (I with your mouse pointer over the value you want to keyframe) to make the light pulse

Richard thanks. I assume this is done in Edit mode to select a face? I did not know one could add materials in Edit mode?

How about the light particles in the1st question?

I tried to add emitters to only a select face but it added to the whole object. See Pic

ALSO about that emitter particles in the first pic and question is that something that is ironed out when rendering say with 1000 samples?


You need at least two materials. One that goes to selected faces and one that covers the rest. Things are made of something so you can’t have just one material on some faces and no material on others.

I added the first material> assigned it> Edit and selected faces> do not know how to add second emitter material. What am I not doing?

Thanks for the help

P.s.s what about the light emitter in the 1st pic and last post ?


Adding and assigning materials is the same for both render engines.

To emit Particles just from a part of the mesh use Weight paint (or just manually assign selected faces to new vertex group) and Particle Density vertex group on Particles tab.

JA12 thank you for the illustration. I was using the assign tab to assign the first material not after creating the 2nd material and desired faces. Little things like that are why pics are so helpful. Thank you again.

Eppo, thanks for your input. However when you state use Weight Paint the state OR just manually assign faces is that two different ways of doing it or are you trying to tell me there are two ways to go about it? Pics are always appreciated and helpful.

HOW ABOUT that first question??? You ALL have skipped over it? Check out the first pic in my first post. There is another question here about the emitter and it’s particles…WHY are they dots instead of as a light would be? Is that a Render deal? Do I need to crank up samples to 3000 when rendering that to appear like a light instead of dust particles?

As a result of weight painting vertex group(s) are created; if you assign something to new vertex group there is weight slider under (default=1) - change value, assign again and you get this weight. So it’s the same in general.
Moving to 1st ;).

As a result of weight painting vertex group(s) are created; if you assign something to new vertex group there is weight slider under (default=1) - change value, assign again and you get this weight. So it’s the same in general.
Moving to 1st ;).

Edit:
Particles as a light ‘cloud’… While light ‘fills area’ (what you can see if there are fine particles as a dust or mist in the air) in ‘real’, no way it works in Blender. You would need several millions of particles, even more emitted light rays and a lot of waiting time at hands.

Since that is an animation, even Cycles volume lights would make significant delays in production ;). You could try, it does look something like this:


and consists of scaled cube where material is to the Volume input attached Emitter node. One simple Emitting plane hidden into the box on top.

Rather make it so that part of the light emitter is visible in camera, assign material index and render on separate render pass, then compozit some glow. Will move the project into reasonable time frame.

Eppo, I do not know where you are referring to. Would you please use a screen grab and steer me thru this?

Your example of an alternate in the pic below is very nice. However I do not know what you stated enough to do it myself. But I would like some light like that, be it as mentioned in your quote here or some steps to achieve it.

“Like me telling you to separate the bell housing from the block drop the torque converter, before hoisting the block out to access the crank pin. Where you will have to pop the fly wheel, pull the pan and remove the collars off the crank. Oh make sure you pop oil pump before you do” Oh make sure you have plastigauge for assembly with anti seize.

Sure I know what I am seeing when I write it out…LOL! But do you? In other words HOW about some illustration Please.
Thanks
NC

Argh, scratch all that.
You wont be able to generate particle system dense enough from vertices to get any light going. Except if that is BI and Hallo. Which … well… wont cut there too probably. You could render separated from that ring faces object with Emission material and composit some glare later which is… is not exactly lighting and takes a lot to get it right in animation and frame.
Here’s that door light if that helps http://www.pasteall.org/blend/29595
I could post pics about Vertex groups and where you can set the Density in Particle system but it can be easily discovered. Not really hidden.
So i’m rather not. Again - have separate faces as object and set Particle system to that if you want to use them anyways. Will be easier.

Eppo,
I am getting back to this step of my art and have a question if you do not mind? First off thanks for the file, it helps me get inside your brain a bit as far as modeling too.

Is there a reason why you added a material this odd shaped or light path shape? It is a Black material and when previewing a render it shows as black and not a light like above? Was this to emphasize as I am not seeing a light result. What or where am I going wrong please?


Apologies for not coming back earlier…
Blackness is due to Cycles not doing volume on GPU - you have to switch to “slow mode” - CPU rendering. To be frank this particular example renders quite fast even on 2-core CPU.
Shape is what i imagine would be light coming from such hanging light box…Feel free to adjust to your idea ;).

thanks for the reply. I do have cycles on and am still getting Black in render (see pic) I do NOT know what is meant by “slow mode” I thought render was render and the only change was the value… I forget the name one value is for preview and the other is render out.

My computer is in my signature it should be fine…I am still getting Black?

I agree with your light fall pattern. I was only describing the best I could.
Please advise
Thanks
NC

Have you set CUDA device in User Preferences to be your NV Q4000? I have no idea if this is supported. If you have done so make sure that you select CPU as a render device on Render tab.
If CPU is the only choice for blender there is no option to select GPU or CPU as a render device: only selectable is Feature Set then.

Maybe you’ŗe still using blender version which does not know anything about volumes? Download, unpack and run one from builder.blender.org

Here is image as it renders on aged laptop with old Intel video card, it’s slow but it works. Blender 2.71 from June 12, downloaded from buildbot.

Hi Eppo,
Thanks I have the option for either CUDA or CPU. If I read you correct you are telling me NOT to use my q4000 and use my CPU?

I am using Blender 2.68 I did not know there were adds for it… I will see if I can find a volumes add on over at builder. thank you
NC

Umm these came out yesterday… (states not proven use at your own risk) Which driver or pack were you referring to. Since this post has been going on before this release?

[TR=“class: file”]
http://builder.blender.org/win.png Windows 64 bit
Official
blender-2.71-b49e6d0-win64.zip
84M
Thu Jun 19 02:19:31 2014

That must be it with the volumes dealeo… See Pic No Joy!

[/TR]


Still rendering using 2.68. That does not have cycles volume and will render as you see it - black. Unpack zip in separate folder and run blender.exe there. Yes, it is cutting edge Blender version and from time to time there could be some issues but in general it has rather more previous bugs straightened out than new ones introduced.
And yes, correct, do not use GPU, it is not here yet.

Thank you for the clarity and sticking with me appreciate it. I DL and will go from there