Help with GLSL glass?

So I have a simple cup thing lol where I have red liquid in. All I did was darken the white color of the bottle and I lowered the transparency. Why does it look weird when you move around and you have different shades.
Potions.blend (362 KB)

You should recalculate the normals of the glass, separate it from the liquid (press p when selected in edit mode), use a solidify modifier on the glass and apply it and add some faces on top of the liquid + assign the right material on them. Than you could join the liquid and the glass back together, select both and press “CTRL+J” in object mode to join them.

Hope that helps.

no sorry wouter. Can you try it and put up the file. Then I can see how you did it.

Here is the edited file: Potions-Edit.blend (409 KB)

I hope that is what you ment to be doing.

*Edit: forgot to join the glass with the liquid. Just select them both and press “CTRL+J” to join them as 1 object agin.

no sorry that really didn’t fix the problem, maybe its just my computer but thanks for trying Wouter.

Your normals are all messed up.
-select your object. Go into edit mode. press N key (in the viewport) to see the properties. Under Mesh Display you’ll see some Normal display options. click on Face. You can scale up the normals for better viewing by adjusting the Normal Size value.
-Press A (in the view port) to select all and then press Ctrl N. This will make all your normals point inward. You probably don’t want this, but at least they are all pointing the same way.
-Now Press W key (in the viewport) and pick Flip Normals in the list that appears. Now all your normals should be pointing outward. Yay!
-Exit Edit mode and hit P to go into the game engine.
It should now look unbroken.
Hope this helps,
Good luck.
Oops, I just read Wouter’s response. I didn’t realise that he had all ready addressed the issue with the normals. Sorry.