Help with HDR

I’ve read the tutorial for HDR on BioRUST.com but it looks like I made something wrong. Here is my blend file: http://www.vegovc.si/~gresta/prenos/hdr_test.blend

Please tell me what I did wrong.

When you are uploading a .blend and it has exterior componnents required to asses it, such as textures, you need to File > Pack Data so that the downloader has all the pieces needed.

-Laurifer

I did that :-?

No DATA packed, I checked and it reports nothing to unpack. You have to save the BLEND file after you pack the DATA. Most real HDRI images are a few MB. Your Blend file would be much larger than what it is. It would be better to ZIP the file after you have DATA Packed, being that Blender does not use compression.

I hope it’s ok now: http://www.vegovc.si/~gresta/prenos/hdr.blend

Use only the HDRI button. You have the HDRI, BLENDE, ZENUP and the ZENDO all activated.

You probably meant Hori not HDRI? If I turn off everything except Hori, this is the result:

http://www2.shrani.si/files/test338203.jpg

I meant Hori :expressionless:

Unpack the DATA then try the rendering again.

Here’s your file. Fixed.
http://mysite.verizon.net/vze3nvj6/Blender/forum/hdr.zip

Download this very soon. I got to delete it to save space!
:smiley:

I downloaded the file and now it’s even wrose than before.

Spin’s file worked for me (reflective sphere with Galileo probe). What are you expecting to see in the render? What’s worse?

I was hoping of getting something like this: http://biorust.com/tutorials/blender-hdri/step3.jpg

ps: sorry for my bad english

I guess I get what you mean…the image is packed but it’s not loaded somehow. Yafray tells me it could not load it although I can see the preview in the World Tab.

EDIT: It seems to be the file format - the HDRI is packed into a .001 file (whatever that is) and after unpacking it and then reloading the newly created HDRI it worked out as it should.

Anyway, if you simply use that file you will definitely get an ugly, black render but the settings used are correct (although I’d use Full GI in the yafray GI tab) and should give you the desired effect. Simply load your own HDRI again and render.

Can you explain me this then?

http://www2.shrani.si/files/mime1340445.png

No.

I downloaded the file you have posted here. Unpacked the texture. Rendered. The result is as expected. A nice, HDRI lit sphere. Even with Hori, Blend, ZenUp and ZenDO activated. In fact, I did not change anything and just unpacked the HDRI (and I deactivated xml export but this should not the reason why it works now).

So, it must be something with your Yafray installation or something. Is there an error printed in the console output?

I have to unpack it too, for it to work.

Saturday Morning: and this server is sloooow today

I’m using linux. I don’t have console.

ok…That tutorial has been irritating me for a while now. I think it’s time that I mention why.

That is NOT a hdr tutorial, what it is is a tutorial on setting up reflections in yafray. At no point does the person mention turning GI on, which is what you need to get IBL.

Anyway, I made a video that runs through the correct setup you need to get this working, I hope it proves useful:

http://www.newcgcreations.com/temp/hdr_setup.avi (5.7 meg)

(Note: To keep filesizes smallish, I ran through this pretty fast…I advise getting VLC media player because it has the option to slow down play speed, making it’s easier to see what buttons Im pushing and to read the text as well)

((Oh, it also plays video more smoothly than any other media player I’ve used))

Yeah, it’s about time there is a good IBL tutorial for the basic setup somewhere. The old BioRust one is heavily outdated (and not even correct IBL, just as you say) yet it is always very close to the top when you google for something like “HDRI Blender”…

Is it possible for someone to contribute this to the wiki? If so, you should consider to do that!

Thanks. This should help but it doesn’t. I’m sure there’s nothing wrong with this speedy tutorial. I’ve made everything as you did, but when I press “render”, blender crashes. I’m guessing there’s something wrong with yafray connected to blender. I have Blender 2.41 (binary) and yafray 0.0.7 from the kubuntu repository. Can someone tell me what to do?

This is from console:

Using Python version 2.4
Starting scene conversion.
Scene conversion done.
Loading plugins …
Registered basicblocks
Registered arealight
Registered globalphotonlight
Registered basicshaders
Registered blendershaders
Registered hemilight
Registered HDRI background
Registered photonlight
Registered mix block
Registered pathlight
Registered pointlight
Registered Shader Background
Registered softlight
Registered spherelight
Registered spotlight
Registered sunlight
Registered sunsky
YafRay plugin loaded
Image initialized
Zbuffer initialized
Segmentation fault

Please someone help. How to compile Blender and yafray? Or maybe there is some kind of other installation possible?