Help with light setup needed

Hi!

As discussed in this thread I have some problems with my Yafray animation.

sketchy suggested that it would help if i uses the blender internal renderer to avoid the problems. I tried to setup a similar looking scene with the internal renderer, but I can’t manage to do that, although the GI and other yafray stuff isn’t needed.

Maybe somebody of you has got the time to correct the light settings in my .blend file.
Everything I tried produced e.g. the yafray background with an ugly lighted cover or a well lighted cover (not as nice as the yafray version) and and ugly background. Maybe this is only du to my lack of knowledge whent it comes to lightning.

So for you, I think this wouldn’t need much time, so please help a lighning newbie :smiley:

thx
g3k

the blend file can be found under www.grasberger.org/home_spot.blend

I tried your BLEND file, but I think you need to fix it first.

The UV mapping is not applied correctly. I had to do it manually fix that. The background is supposed to have an image? Looks like something is not correct.

Can you upload the exact project that is causing you the trouble.

DATA PACK it, then save it then upload it.

With that, I can help you with the lighting, possibly.

----EDIT----
Also, I noticed that you “sort of” UV mapped it. You need to create SEAMS to UVmap the Magazine. Then you need to UnWrap the MAP to apply a texture.

Also, you don’t need ‘that’ many layers of vertices for your magazine. A simple cube re-shaped will do.

  1. why did you do the book the way you did? why not just a cube with a texture?
  2. i’m getting some 250 frames inbetween the rendered frames
  3. the lighting is washed out…
    maybe something is up with my install???

EDIT:from here it looks like you have some movie settings enabled in your background texture.?

thx for your comments. funnily the blend file works with my machine (osx, 2.37)
Textures should be packed, I checked it before uploading (I will check them tomorrow again).

the book is simply a cube (subdivided for the slight curve), with the texture … I admit that there would be a more elegant approach to it, yes, but all those things with unwrapping … is that really necessary?

what do you mean with the “washed out lightning”??
I noticed, that light settings with the yafray and blender render are completely different to handle …

as i said before, I’m going to check it again tomorrow, but thx in advance!!

Ok, i checked the file again, and there was something incorrect with the textures. What I noticed, that it now works when you Unpack Data again, then the right textures are there in the rendering as well.

Apart from the issue with my bad UV mapping, the renderings should look like the pictures in the other thread given above.

The anim and movie settings in the texture tab are there as soon as I make an image texture, but nothing was changed in there.

the download for the blend file is the same, i simply wrote over it. I checked the file on another machine, where the original textures aren’t present, and with blender 2.4alpha too. It is working there, so now you shouldn’t have any problems as long as you don’t forget to unpack data.

As I said before, my problem is with the different behavior of yafray and blender lights, and I can’t manage to get the same impression with the blender internal renderer as with yafray (which somehow messes up my animations) (if you have a clue what might cause my problems in yafray and can tell me what to correct I’m happy too :D)

thx to all of you!!!
g3k

I am rendering the animation now, so I’ll post back here with some results.

So far it looks like the typical problem when using YafRay for animations. Not Good. YafRay in Blender is not very good for animations.

I did a DVD menu. A very short animated clip with YafRay. This thing was only a few seconds long, but I had to use the HIGHEST and FULL settings of Quality in YafRay to make it look semi-decent and it took over 16 hours to render.

OK, Here are my results…
Click here to watch Magazine Animation

There is definately YafRay Artifacts with the lighting on the background. It is also seen on the magazine as well, but not as noticeable. This is something that you cannot avoid. You are better off using Blender’s Internal rendering engine, however, you may still have the same problem with AO turned on.

Yeah, my first impression was, that yafray doesn’t shoot enough sample rays per pixel, and that those are the reasons for the artifacts.

I am not against the blender internal renderer, but when I tried out the renderers, it was easier to get better results in yafray as in the internal one.

Now I set up the scene for yafray, but I am not capable of getting the same results with the internal renderer (due to the different light behaviour; somehow when I render the scene as is with the internal renderer there is tooo much overshoot, when I reduce the Energy of the lights, the impression of the scene is not as good as with yafray (see my first post).

thx for your work so far!

Edit: somehow your spot seems to be not on the server (some error with the filename, according to my browser)

i’ve been playing with your project too.
i think your going to have trouble with the yafray.
you could try not having a background (and therefore a shadow)
and just set the world settings as white or grey or something.
it won’t look as fancy i think, but i notice that the cube doesn’t seem to have the texture problem your plane does…
i’ve got it looking decent in blender internal, but probably not as good as you wanted it.

good luck.

could you post a still image of your version?

I tried out again to look at your movie, Spin. This time, extracting the the locations out of the html source helped :smiley:

those artifacts are definitely the same, I encountered while rendering this stuff.

Do you have any clues how to “project” yafray light settings to blender internal? All I know so far has only got to do with trial and error, which is a very long approach to it :smiley:

but thx for your efforts so far.

hy, sorry for 3 posts in a row, but i noticed something, when i played around with yafray:

when i turn off “tune photons” the noise is not present in alle the pictures, but the whole picture looks very bluish. Is there a way, that I can get the gray look back, without the “tune photons” button off? (tune photons draws the photon map into the pic, what made the grain, i think)

Change the deafault blue to white