Help with Node editor

Hey guys, I’m triyng my best to render a few basic object in Blender. Anyways here is a picture of what i’m doing.
I’m trying to a gloss to my ceramic cup, yet when I render it it look like literally nothing has changed. I’m stumped.

The Mix shader needs to be connected to the Surface input of the Material Output

You also need better lighting setup

Hey Richard.

Thanks for the help, It solved my problem adding light helped out. I do have another problem it seems, when I’m trying to Render my scene I’m not getting my color in the render.

From the pictures you provided it does not appear the objects in your scene have any color assigned to them, which would explain why there is no color in the render. You have a brown color for the viewport color, however that is just the color the object displays in the viewport, that color is separate from the rendered color. Try clicking on the white box on the Diffuse node, then on the color picker, then on the brown color you have set for the viewport color. This should set the diffuse color for your table to the same brown color you have set up to display in the viewport.

To be a bit more specific on what the viewport color does, it is the color of the object in solid-color object mode, as seen in the viewport. Changing this setting is useful for easily telling what materials are applied do different objects in your scene, without actually affecting the render.

That worked perfectly, thanks you very much.