help with Particles bobbing through collision object before settling to the top....

Hello everyone, so here’s my problem (one of many of course), how do I stop particles from protruding thru a collision object, specifically, how do i stop object particles from doing this?.

Here is what I have in the scene, a sphere emitter, a plane (collision), a plane (shadows only),and two small sphere objects as the particles, plus the usual camera and lights.

Blender Version 2.58

Emitter Settings:

Emissions Settings-
Emit from Volume(played with the other settings as well)
Even Dist-checked
Random activated

Velocity Settings:

Emitter geometry-
Normal - 4.240(for an explosion effect, by choice),
Rotation -0.167

Emitter object


Rotation Settings

Physics Settings:

Size = 0.466
Random Size = 1.000
Mass = .010
Multiply Mass - Unchecked
Forces = 0
Intergration - Midpoint
All other settings are default.

Collision Settings:

All set to zero except-
Particle Damping = 0.650

Here’s what happens:

Alt A - Object particles are released as they should

When particles are released from the Emitter some of them bob part way through the collision plane and get stuck in there but travel as they should, some bob through the collider and nest back on top and do what they are meant to do. At one stage some stop, hovering above the collider never actually hitting the plane.

What I have tried-

Nesting the particles flush with collision plane:

Enter edit mode and move the Origin of the objects used for the particles to the bottom of the object which worked perfectly so long as the Object particles are all the same size, therefore I had to set the random size option to zero (but it’s not what I want), then move the shadow plane just under so the Object particles sit on top of it to get the correct shadow effect, however, the particles that bob through the collider also bob through the shadow plane and because this plane is rendered(although not seen),half of the particle dissappears, though only for a micro second or two, it is still very noticable.

Particles bobbing through and getting stuck:
Move the Particle sources origin to the bottom of the object.

Particles bobbing through the collider:

Once these problems are fixed this effect will be used in an explosion caused by a meteor crashing into a road, hill top, or some other solid surface.

more info can be aquired if needed

any suggestions would be immensly appreciated

No I did not mention the hovering with size deflect on in the other thread my bad sorry Mike

So Here’s an image with size deflect on, the particles don’t touch the collision plane.

And one with Size Deflect Off, the object particles travel through the collision plane.

Although not what I will be using in the end result, it depicts what is happening, same result as with the second image (size deflect off), this time with a “shadows only” plane added

To stop the particles bobbing you could try setting the particle cache step to 1. You could try cheating to get the particles to stop on the plane; bake the particle animation and then move the plane so that the particles don’t penetrate.

The collision for particles is point based… so the object origin is what collides with the collision surface… which is why “object” particles will intersect a bit and also this is the reason that the object origin should be at the centre of mass rather than at the base like you tried in the other thread.

When you use size deflect the particle size is a single value… essentially collision goes from point based to sphere based…

This is all well and good, but if your particle object has dimensions that cannot be approximated by a sphere then it will have inaccurate collision. (your long flat objects will always either intersect a bit or float a bit on one dimension or another.)

If you really think that the intersections will be noticable then particles are not the answer… instead you’ll need actual objects and will need to simulate n the game engine…

Collision in teh game engine is also a sliding scale (starting with the cheapest and adding complexity of calculation as we go: point based, sphere based, bounding box based, convex hull based or indeed a compound collision object) there’s also some stuff like capsule I believe!

At the end of the day there’s always a level of approximation and your system will thank you for doing the most approximate thing you can get away with in your shot!

Michael sir u r a legend, BGE did exactly what I needed, mate thanks a heap, although it’s the first time I have actually gone into depth as to the BGEs functionality in regards to SFX, along with Pils Fracture addon and some awesome tutorials, I found it quite easy to use(for the intended purpose anyways), so thanks again.

I’ll be back again no doubt lol